The default bug view has changed. See this FAQ.

onchange is not fired when container has "overflow" altered by ":hover" rule

RESOLVED FIXED

Status

()

Core
Event Handling
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: gmice, Unassigned)

Tracking

({regression})

Trunk
x86
All
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed by bug 722599])

Attachments

(1 attachment)

269 bytes, text/html
Details
(Reporter)

Description

5 years ago
Created attachment 613242 [details]
bug.html

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:11.0) Gecko/20100101 Firefox/11.0
Build ID: 20120312181643

Steps to reproduce:

I have an <input> element wrapped by a <div> element. There're 2 css rules applied to the <div> element:
div { overflow: hidden; }
div:hover { overflow: visible; }

Steps:
1. Click the <input> element, keeping mouse cursor hover on input
2. Type something, do not enter
3. Move mouse cursor to anywhere blank, click

onBlur event from <input> element is fired but onChange event is missing.

Another interesting behaviour is, after clicking the <input> element, move out mouse cursor while leaving input cursor in <input>, type something and then click outside. Both onBlur and onChange event are fired.


Actual results:

onChange event is missing.


Expected results:

onChange event is fired.

Comment 1

5 years ago
Regression window:
Last Good : 05-Jan-2007 0856
First Bad : 06-Jan-2007 0533
Pushlog:
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2007-01-05+06%3A00%3A00&maxdate=2007-01-06+05%3A33%3A00&cvsroot=%2Fcvsroot

Suspected: Bug 265047
Blocks: 265047
Status: UNCONFIRMED → NEW
Component: Untriaged → Event Handling
Ever confirmed: true
Keywords: regression
OS: Windows 7 → All
Product: Firefox → Core
QA Contact: untriaged → events
Version: 11 Branch → Trunk
This happens because the change event is fired by layout, so reframing with careful timing will cause it not to be fired.  I think the right fix here is to make the event be dispatched by content instead of layout.  Mounir, are you interested in doing that?  :-)
Bug 722599 is about making the change event fired by the content. There is someone currently working on that. There was no activity in the bug recently but he told me on IRC he will be back working on it.
Depends on: 722599
Attachment #613242 - Attachment mime type: text/plain → text/html
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed by bug 722599]
You need to log in before you can comment on or make changes to this bug.