Closed Bug 743627 Opened 8 years ago Closed 8 years ago

The background of the AwsomeBar is a different color after scrolling on Motorola phones

Categories

(Firefox for Android :: General, defect)

14 Branch
ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 14
Tracking Status
blocking-fennec1.0 --- soft

People

(Reporter: AdrianT, Assigned: lucasr)

Details

Attachments

(2 files)

Fennec/14.0a1 2012-04-08
Device: Motorola Droid 2(Android 2.3)/Motorola Droid Pro ( Android 2.3)

Steps to reproduce:
1. Open Nightly.
2. Tap on the AwesomeBar.
3. In every tab attempt to scroll the content.

Expected results:
Highlight may be briefly displayed but when the scroll action is ended the background is the same as the background in the beginning.

Actual results:
The background remains painted a different color after a scroll attempt.

Notes: 
I was unable to reproduce the issue on other phone.
CC'ing Sriram for recommended assignee.
blocking-fennec1.0: --- → ?
I found this happening when I was trying to fix another bug. It seems like removing the focus away makes Samsung and Motorola to use a off-whitish color for the ListView. If you tap back on the awesome-bar-search, everything turns white. Probably lucasr can address this as he did some work to remove focus on tabs in awesomebar.
blocking-fennec1.0: ? → -
blocking-fennec1.0: - → soft
Assignee: nobody → lucasr.at.mozilla
Morotola devices do something wrong with cache color hint. We have to explicitly define it.
Could you please make it all CAPS to be consistent with all other colors values we use -- like #E5E5E5?
Attachment #614451 - Flags: review?(mark.finkle) → review+
https://hg.mozilla.org/mozilla-central/rev/68a7e8713ea8
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 14
Verified fixed on:
Nightly 15.0a1 (2012-05-21)
Device: Motorola Droid Pro
OS: Android 2.3.4

No background color changes.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.