Use espressive's products service to populate product/version data in nightly crash trends

VERIFIED FIXED in 9

Status

Socorro
Webapp
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: brandon, Assigned: espressive)

Tracking

unspecified

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Comment hidden (empty)
(Assignee)

Updated

6 years ago
Duplicate of this bug: 751269
I just wanted to capture some notes from bug 751269 (which was duped) to add some context to this bug. 

Schalk please add some additional context if you can.

Currently /crash_trends only lists 'Fennec' in the product selection list. 'FennecAndroid' should too.

Expected:
'FennecAndroid' is in the product filter list for crash_trends
(Assignee)

Comment 3

6 years ago
Yeah so, that is the reason for this bug ;) Those values are currently hard coded and so this will be fixed by using my service instead.
(Assignee)

Updated

6 years ago
Assignee: bsavage → sneethling
Target Milestone: --- → 10
(Assignee)

Comment 4

6 years ago
Sent pull rquest :: https://github.com/mozilla/socorro/pull/571

TEST CASE
----------

Values for the products drop down is now loaded from the DB so, all products that are expected to be available should be visible.

Comment 5

6 years ago
Commits pushed to master at https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/1df3f4418c0003f656837bfa5833b50a37819946
using products service to populate drop down fixes bug 743659

https://github.com/mozilla/socorro/commit/15b8cf09a2e39541018c3ae7cfa7e3c5a921163b
Merge pull request #571 from ossreleasefeed/use-products-service-743659

using products service to populate drop down fixes bug 743659

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Updated

6 years ago
Target Milestone: 10 → 9
Created attachment 623763 [details]
qa - verified

Looks great - thanks espressive. QA verified, the product list for the crash_trends report is being updated by the values in the db.

Updated

6 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.