Last Comment Bug 743896 - Fix test failure misattribution for timeouts in the unix testrunner
: Fix test failure misattribution for timeouts in the unix testrunner
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla14
Assigned To: Terrence Cole [:terrence]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-09 18:58 PDT by Terrence Cole [:terrence]
Modified: 2012-04-12 10:21 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v0 (1.64 KB, patch)
2012-04-09 18:58 PDT, Terrence Cole [:terrence]
dmandelin: review+
Details | Diff | Splinter Review

Description Terrence Cole [:terrence] 2012-04-09 18:58:16 PDT
Created attachment 613467 [details] [diff] [review]
v0

In the unix task runner, when we kill tasks, we should be checking and returning bool if we kill, so that we then run waitpid in timeout mode.  We weren't, so tasks were never failing with timeout, only with failure.  It turns out, that this is not safe anyway, since this will race against signal delivery.  We're better off just removing this hack and letting the timeout cutoff be fuzzy.
Comment 1 Terrence Cole [:terrence] 2012-04-11 10:04:45 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/03cb4bb56621

Note You need to log in before you can comment on or make changes to this bug.