Closed Bug 743917 Opened 8 years ago Closed 8 years ago

launch of basic app in a chromeless window - offline

Categories

(Firefox for Android :: Web Apps (PWAs), defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 741624
Firefox 15
blocking-kilimanjaro +

People

(Reporter: jarguello, Unassigned)

References

Details

(Whiteboard: [Phase 2][k9o:p1:fx15?])

This meta bug covers the story where a user launches an app when there is no connectivity and webRT handles it. 

Flow - offline:
* User taps the icon on the home screen
* App opens in a chromeless window
    ** If manifest says it  does not work offline then display appropriate message
    ** Otherwise, app works as designed
* For example: Text editor app
blocking-kilimanjaro: --- → +
Whiteboard: [Phase 2] → [Phase 2][k9o:p1:fx15?]
Blocks: k9o-webrt
Mark - Is there any special behavior required that would be need to be implemented to support offline mode in fennec native for a chromeless environment? Or would this come by default if chromeless support was implemented?
(In reply to Jason Smith from comment #1)
> Mark - Is there any special behavior required that would be need to be
> implemented to support offline mode in fennec native for a chromeless
> environment? Or would this come by default if chromeless support was
> implemented?

The special behavior has nothing to do with being "chromeless". We need to add code to show a better offline error message. Is that (better offline error message) in a different bug?
(In reply to Mark Finkle (:mfinkle) from comment #2)
> (In reply to Jason Smith from comment #1)
> > Mark - Is there any special behavior required that would be need to be
> > implemented to support offline mode in fennec native for a chromeless
> > environment? Or would this come by default if chromeless support was
> > implemented?
> 
> The special behavior has nothing to do with being "chromeless". We need to
> add code to show a better offline error message. Is that (better offline
> error message) in a different bug?

Don't know. Should we track a different bug in fennec native for it? Also, since this behavior has nothing do with being "chromeless," should this bug be marked as "invalid?"
Looks like bug 741624 is a good dupe
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 741624
You need to log in before you can comment on or make changes to this bug.