Post-3.6 users should not see upgrade message

RESOLVED FIXED

Status

Websites
Firefox Start
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: wenzel, Assigned: jpetto)

Tracking

Details

(Reporter)

Description

6 years ago
Bug 735411 comment 6:

"Some Firefox 4+ users have set the old Start Page (www.google.com/firefox) as their homepage in certain circumstances. I have seen many tweets claiming "The Start Page says: You're not on the latest version of Firefox. My Firefox is up-to-date!" That means the static copy on the Start Page is inappropriate. Do you have a plan to implement some kind of version check on the Start Page? If you've discussed that, please discard my comment."

Over to Christie for a product decision, please wontfix or assign to jpetto depending on the outcome.
(Reporter)

Comment 1

6 years ago
My 2 cts: If these users deliberately set their homepage to the old one, then I am not too empathetic. However, if there's a chance they upgraded but their homepage was not upgraded along with it, then this is a bigger deal.

Plus, checking the UA for >= 4.0 wouldn't be too hard, so we could do it for the UX win.

Always checking for the precise latest version, however, is out of scope for this project.
Firefox 4+ users have chances to see the old Start Page:

* he/she changed his/her homepage then restored to default.
* he/she bookmarked the Start Page.
* he/she visited the Start Page somehow using web search.
  The page has been indexed by search engines, so it's no longer a in-product page.
  https://www.google.com/search?q=Google+Firefox&hl=en
  http://www.bing.com/search?q=Google+Firefox
  http://search.yahoo.com/search?p=Google+Firefox
A ride-along: please consider users on Mac OS X v10.4 (Tiger) and/or PowerPC Mac 
who cannot upgrade to Firefox 4+

http://www.mozilla.org/en-US/firefox/3.6/system-requirements/
http://www.mozilla.org/en-US/firefox/12.0/system-requirements/
(In reply to Kohei Yoshino from comment #3)
> A ride-along: please consider users on Mac OS X v10.4 (Tiger) and/or PowerPC
> Mac 
> who cannot upgrade to Firefox 4+

Oh, was resolved in Bug 742564.
(Reporter)

Comment 5

6 years ago
Jon: I just looked at <https://github.com/mozilla/fx36start/commit/2ad114aa90cbd0eed1ddd4aa47222d8a45437f45> and the intent is good, but the logic is too narrow: People could have Firefox 3.0 and would still need to see the popup. I suggest you change the logic to not show the popup if they have Firefox 4 or later.
Assignee: ckoehler → jon
(Assignee)

Comment 6

6 years ago
The version checking has been improved. The conditions to show the upgrade message are now as follows:

- must be a Mozilla browser
- must not be PPC 10.[0-4]
- version must be less than 4

Comment 7

6 years ago
Commit pushed to master at https://github.com/mozilla/fx36start

https://github.com/mozilla/fx36start/commit/a76336dc2304ecff31ef69c8509bf12c7c212b51
using regex to parse browser/version. bug 744055
(Reporter)

Comment 8

6 years ago
looks good
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Keywords: qawanted
qa-verified http://start-dev.allizom.org/en-US/
Keywords: qawanted

Updated

6 years ago
Duplicate of this bug: 710542
You need to log in before you can comment on or make changes to this bug.