Implement Apps in the Cloud client for WebRT on Android

RESOLVED WONTFIX

Status

Web Apps
AppsInTheCloud
RESOLVED WONTFIX
6 years ago
5 years ago

People

(Reporter: anant, Assigned: Harald)

Tracking

(Depends on: 2 bugs)

unspecified
ARM
Android
Dependency tree / graph

Firefox Tracking Flags

(blocking-kilimanjaro:+)

Details

(Reporter)

Description

6 years ago
This bug is to track implementation of the AITC client on Android. This work is likely to reuse a lot of code from bug #744257 once it lands on mozilla-central, and will primarily entail writing UI that hooks to core AITC functionality that will be in Gecko.
Jen - Should this bug be tracked here or in Fennec Native -> Web Apps?
@Jason no. Since this is part of a service.

Updated

6 years ago
Whiteboard: [marketplace-beta?]
The first time you open marketplace user has to log into PersonID.  This also logs you into the dashboard


If you go directly to the dashboard you will have to login

Install should not fail if AitC fails to be written to. We should keep retrying until we can sync.

The dashboard will live on apps.persona.org

How to get to the dashboard on the desktop:
* Direct URL - apps.persona.org
* about:apps - redirects to apps.persona.org
* link from Marketplace - From the Purchased App section have a link to about:apps

Operations of the dashboard:
* Install new apps
* Re-install "installed" apps (per device)
* View all apps in the cloud
** nice-to have is to distinguish on device from cloud 

Non-goal:
* Launching an app from the dashboard
After talking with Finkle we do not think there is an API to "install a shortcut" to the home screen from the AitC dashboard. 

Is this true?
Mark, given that this April 12th, is there still time to implement this feature for fennec native 14? Or is too late?
(Assignee)

Comment 6

6 years ago
(In reply to Jennifer Arguello :ticachica from comment #4)
> After talking with Finkle we do not think there is an API to "install a
> shortcut" to the home screen from the AitC dashboard. 
> 
> Is this true?

Solution for creating a shortcut: Just call install() again for an app, which triggers "Re-install", see attachment on bug 738546: https://bug738546.bugzilla.mozilla.org/attachment.cgi?id=614065

I also guess Fennec will still use about:apps for a while, as there is no mobile-enabled dashboard for Phase 1.

The mozApps API still has to evolve if we want more options on the dashboard (push to device, see which apps are installed on which devices, list of all synced devices per sync account)

Updated

6 years ago
Whiteboard: [marketplace-beta?]

Updated

6 years ago
blocking-kilimanjaro: --- → ?

Updated

6 years ago
blocking-kilimanjaro: ? → +

Updated

6 years ago
Depends on: 744457
Is bug 744457 a dependency (like what I just did) to this bug? Or is it a duplicate?

Updated

6 years ago
Depends on: 746384
(Assignee)

Comment 8

6 years ago
rnewman's meeting notes:

 * BrowserID client library [digitarald]
   * Built on top of Sync libraries: existing, tested crypto + utilities, unit test framework, etc
   * Integration tests FTW
   * Can be built and tested independently of Android system integration: Account not needed yet.
 * Android account class and integration [big collaborative ball of mud]
   * Multiple version support: depends on research that Nick and Chenxia are doing
   * Android token access for AITC's, Sync's, and third-party app's needs.
 * Content Provider for Fennec app storage [digitarald, rnewman can review]
 * SyncAdapter instance [rnewman, nalexander, whoever]
   * Should allow for selection of Sync and/or apps sync; UX questions about delayed Sync setup — requires correct setup of Persona account for storage of credentials beyond just Sync key.
 * AITC client library [nalexander, gps, anant, digitarald…]
   * Again, built on top of Sync libraries: should be relatively straightforward, at least for first draft.
 * Fennec build and manifest integration [rnewman]
 * Future: port Sync to use Persona account
(Assignee)

Updated

6 years ago
Depends on: 765322
(Assignee)

Updated

6 years ago
Duplicate of this bug: 765321
Depends on: 768554
No longer depends on: 765322
Duplicate of this bug: 803751
No concrete plans to ship AITC, so marking this as WONTFIX. We can reopen if that decision changes.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.