crash in mozilla::layers::ContainerLayer::ComputeEffectiveTransformsForChildren @ libpvrANDROID_WSEGL

RESOLVED DUPLICATE of bug 752368

Status

()

--
critical
RESOLVED DUPLICATE of bug 752368
7 years ago
7 years ago

People

(Reporter: blassey, Assigned: vlad)

Tracking

({crash, topcrash})

unspecified
ARM
Android
crash, topcrash
Points:
---

Firefox Tracking Flags

(blocking-fennec1.0 +)

Details

(Whiteboard: [native-crash][gfx], crash signature)

This bug was filed from the Socorro interface and is 
report bp-49cb3275-34e7-4827-a6c9-8e17e2120410 .
============================================================= 
This is the #4 top crash for today (granted that means its only 3 reports). Wanted to get a bug on file for it.

0 	libpvrANDROID_WSEGL.so.1.1.17.4403 	libpvrANDROID_WSEGL.so.1.1.17.4403@0x6b4 	
1 	libxul.so 	mozilla::layers::ShadowContainerLayerOGL::ComputeEffectiveTransforms 	gfx/layers/opengl/ContainerLayerOGL.h:138
2 		@0x49481a22 	
3 	libIMGegl.so.1.1.17.4403 	libIMGegl.so.1.1.17.4403@0x61be 	
4 	libGLESv2_POWERVR_SGX540_120.so.1.1.17.4403 	libGLESv2_POWERVR_SGX540_120.so.1.1.17.4403@0x19c4e 	
5 	libutils.so 	_ZN7android7RefBase12weakref_type7decWeakEPKv 	
6 	libutils.so 	_ZNK7android7RefBase9decStrongEPKv 	
7 		@0x49481a5e 	
8 	libIMGegl.so.1.1.17.4403 	libIMGegl.so.1.1.17.4403@0x6072 	
9 	libGLESv2_POWERVR_SGX540_120.so.1.1.17.4403 	libGLESv2_POWERVR_SGX540_120.so.1.1.17.4403@0x2a026 	
10 	libIMGegl.so.1.1.17.4403 	libIMGegl.so.1.1.17.4403@0x61ea 	
11 	libxul.so 	mozilla::layers::LayerManagerOGL::SetupPipeline 	gfx/layers/opengl/LayerManagerOGL.cpp:982
12 	libxul.so 	mozilla::layers::LayerManagerOGL::Render 	GLContext.h:2024
13 	libxul.so 	mozilla::layers::LayerManagerOGL::EndTransaction 	gfx/layers/opengl/LayerManagerOGL.cpp:454
14 	libxul.so 	mozilla::layers::LayerManagerOGL::EndEmptyTransaction 	gfx/layers/opengl/LayerManagerOGL.cpp:427
15 	libxul.so 	mozilla::layers::CompositorParent::Composite 	gfx/layers/ipc/CompositorParent.cpp:224
16 	libxul.so 	RunnableMethod<mozilla::layers::CompositorParent, void , Tuple0>::Run 	ipc/chromium/src/base/tuple.h:383
17 	libxul.so 	MessageLoop::RunTask 	ipc/chromium/src/base/message_loop.cc:318
18 	libxul.so 	MessageLoop::DeferOrRunPendingTask 	ipc/chromium/src/base/message_loop.cc:326
19 	libxul.so 	MessageLoop::DoWork 	ipc/chromium/src/base/message_loop.cc:426
20 	libxul.so 	base::MessagePumpDefault::Run 	ipc/chromium/src/base/message_pump_default.cc:23
21 	libxul.so 	MessageLoop::RunInternal 	ipc/chromium/src/base/message_loop.cc:208
22 	libxul.so 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:201
23 	libxul.so 	base::Thread::ThreadMain 	ipc/chromium/src/base/thread.cc:156
24 	libxul.so 	ThreadFunc 	ipc/chromium/src/base/platform_thread_posix.cc:26
25 	libc.so 	__thread_entry 	
26 	libc.so 	pthread_create
Crash Signature: [@ libpvrANDROID_WSEGL.so.1.1.17.4403@0x6b4] → [@ libpvrANDROID_WSEGL.so.1.1.17.4403@0x6b4] [@ libpvrANDROID_WSEGL.so.1.1.17.4403@0x6b4 ]

Updated

7 years ago
OS: Linux → Android
Hardware: All → ARM
Summary: crash in libpvrANDROID_WSEGL → crash in mozilla::layers::ContainerLayer::ComputeEffectiveTransformsForChildren @ libpvrANDROID_WSEGL
Whiteboard: [native-crash][gfx]
2nd top crash in 3 day report since all the other crashers have been fixed except one.
Keywords: topcrash
(Reporter)

Updated

7 years ago
Keywords: qawanted
added qawanted to get STR
I think I need the specific device.  I can't repro with the Samsung Galaxy S II
GT-I9100G is the Samsung Galaxy S II

Comment 6

7 years ago
(In reply to Naoki Hirata :nhirata from comment #3)
> URL : 
> http://www.futureofthebook.org/blog/archives/2012/04/
> these_drawings_date_from_1982.html 
> http://www.themalaysianinsider.com/malaysia/article/in-schools-politics-
> rears-a-sinister-comic-appearance/ 
> http://www.themalaysianinsider.com/malaysia/article/tsunami-warning-lifted/
> 
> Devices : GT-I9100G, Nook Tablet, Kindle Fire

I can check the Fire, if u can comment on str's.
(In reply to Kevin Brosnan [:kbrosnan] from comment #5)
> GT-I9100G is the Samsung Galaxy S II

Different CPUs/GPUs if you trust this article: http://10division.com/samsung-galaxy-s2-gt-i9100-vs-gt-i9100g-ultimate-comparison-guide-all-you-need-to-know/

Fire would be great.  try going to one of these sites and hitting the home button while fennec is loading or letting fennec go to sleep at this site.. or going to this site and hitting the on/off button to force it to go to sleep mode.

I noticed that I had some weird graphic issues with the flash and when I came back it caused pretty bad graphic defects.  I think it might be related to this crash.

Comment 8

7 years ago
unable to reproduce on the kindle fire, 04-19-2012 build.   tried the urls in comment 6, and played around with the sites.  no crash with this signature.

Meanwhile, i did hit crash bug 746946, when tapping awesomebar.  but thats not this bug.
this is #50 and #58 in the top crash list, so minus'ing. Please renome if it climbs the list again
blocking-fennec1.0: ? → -

Updated

7 years ago
Crash Signature: [@ libpvrANDROID_WSEGL.so.1.1.17.4403@0x6b4] [@ libpvrANDROID_WSEGL.so.1.1.17.4403@0x6b4 ] → [@ libpvrANDROID_WSEGL.so.1.1.17.4403@0x6b4] [@ libpvrANDROID_WSEGL.so@0x6b4]

Comment 10

7 years ago
Volume has gone way down so removing the top crash keyword.
Keywords: topcrash
Duplicate of this bug: 740727

Comment 12

7 years ago
There are currently 332 crashes in 14.0b1 making it #1 unfixed top crasher.
blocking-fennec1.0: - → ?
Crash Signature: [@ libpvrANDROID_WSEGL.so.1.1.17.4403@0x6b4] [@ libpvrANDROID_WSEGL.so@0x6b4] → [@ libpvrANDROID_WSEGL.so.1.1.17.4403@0x6b4] [@ libpvrANDROID_WSEGL.so@0x6b4] [@ libpvrANDROID_WSEGL.so@0x7b4]
Keywords: topcrash

Updated

7 years ago
Crash Signature: [@ libpvrANDROID_WSEGL.so.1.1.17.4403@0x6b4] [@ libpvrANDROID_WSEGL.so@0x6b4] [@ libpvrANDROID_WSEGL.so@0x7b4] → [@ libpvrANDROID_WSEGL.so.1.1.17.4403@0x6b4 ] [@ libpvrANDROID_WSEGL.so@0x6b4 ] [@ libpvrANDROID_WSEGL.so@0x7b4 ]
Note that the stack (definitely the ComputeEffectiveTransformsForChildren frame, maybe earlier) is bogus -- the actual crash seems to be a result of SetupPipeline -> SetLayerProgramProjectionMatrix -> CheckAndSetProjectionMatrix, which just sets some variables and doesn't make any GL calls at all.

SetLayerProgramProjectionMatrix loops over some stuff and calls some member functions; I can see this potentially happening if we had a bogus address in there?
Assignee: nobody → vladimir
blocking-fennec1.0: ? → +
Needs STR to make any traction, otherwise I'm just guessing.

Comment 15

7 years ago
There are no crashes after 14.0a2/20120518. It's probably a dupe of bug 752368.
still no repro steps, but we should wait to see if crashes still appear.

Comment 18

7 years ago
Another day and no crashes.  Let's dupe this off to bug 752368.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 752368
Clearing qawanted from a dupe.
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.