If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Different page versions are displayed for news.google.com in portrait and landscape

RESOLVED INVALID

Status

()

Firefox for Android
General
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: AdrianT, Unassigned)

Tracking

14 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 613930 [details]
logs

Fennec/14.0a1 2012-04-10
Device: Motorola Droid 2 (Android 2.3)

Steps to reproduce:
1. Set device to portrait. Go to news.google.com.
2. Switch to the classic version (Desktop).
3. Wait for the page to load and observe the layout.
4. Rotate the device to landscape.
5. Observe the layout.
6. Rotate the device back and observe the content.

Expected results:
The content is the same for portrait and landscape. If the content is different it should be consistent: the same content is always displayed in portrait and the same content is always displayed in landscape.

Actual results:
The first loaded content in portrait just shows the center column with the news. After the user first does a page rotation Firefox always displays the full content with the News menu on the left and the related sections column on the right.

Note: 
The issue is also reproducible on the Android Browser
If this is also reproducible on the stock Android browser, then this is probably invalid.

Comment 2

6 years ago
google is doing responsive web design.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.