Last Comment Bug 744417 - B2G Wifi: better nsIDOMWifiManager.forgetNetwork function
: B2G Wifi: better nsIDOMWifiManager.forgetNetwork function
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Device Interfaces (show other bugs)
: Trunk
: x86 Linux
: -- normal (vote)
: mozilla14
Assigned To: Fabien Cazenave [:kaze]
:
: Andrew Overholt [:overholt]
Mentors:
Depends on:
Blocks: b2g-wifi
  Show dependency treegraph
 
Reported: 2012-04-11 08:21 PDT by Fabien Cazenave [:kaze]
Modified: 2012-04-13 01:38 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch proposal (1.76 KB, patch)
2012-04-11 08:21 PDT, Fabien Cazenave [:kaze]
mrbkap: review+
Details | Diff | Splinter Review
patch proposal (3.94 KB, patch)
2012-04-11 09:53 PDT, Fabien Cazenave [:kaze]
no flags Details | Diff | Splinter Review
patch proposal (2.17 KB, patch)
2012-04-11 09:58 PDT, Fabien Cazenave [:kaze]
no flags Details | Diff | Splinter Review

Description Fabien Cazenave [:kaze] 2012-04-11 08:21:29 PDT
Created attachment 614009 [details] [diff] [review]
patch proposal

The current `forgetNetwork' implementation is buggy because it couldn’t be tested so far.

Here’s a quick fix that works with my current Gaia tree:
https://github.com/fabi1cazenave/gaia/tree/wifi
Comment 1 Fabien Cazenave [:kaze] 2012-04-11 08:51:20 PDT
mrbkap > for my information, what’s the difference between

    var request = this.createRequest();

and

    var request = Services.DOMRequest.createRequest(this._window);

? In DOMWifiManager.js, the latter is only used for `forget' — the former is used everywhere else.
Comment 2 Blake Kaplan (:mrbkap) (PTO until Jan. 2, 2017) 2012-04-11 09:35:45 PDT
Comment on attachment 614009 [details] [diff] [review]
patch proposal

The two versions of createRequest are equivalent. Please do change the one in forget for consistency though.

Thanks a lot and sorry for the typos!
Comment 3 Fabien Cazenave [:kaze] 2012-04-11 09:53:14 PDT
Created attachment 614042 [details] [diff] [review]
patch proposal

same patch, now using `this.createRequest()' for better consistency.
Comment 4 Fabien Cazenave [:kaze] 2012-04-11 09:58:10 PDT
Created attachment 614043 [details] [diff] [review]
patch proposal

sorry, did a `git diff >> patch' instead of a `git diff > patch'.
Comment 5 Blake Kaplan (:mrbkap) (PTO until Jan. 2, 2017) 2012-04-13 01:38:53 PDT
https://hg.mozilla.org/mozilla-central/rev/63a7d74d01d8

Note You need to log in before you can comment on or make changes to this bug.