Status

Other Applications
ChatZilla
VERIFIED FIXED
17 years ago
12 years ago

People

(Reporter: Garth Wallace, Assigned: Robert Ginda)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
As of Mozilla 0.8.1, using the /quit command in Chatzilla gives an error "Sorry,
"quit" not implemented". The only way to log off of a network is to close
Chatzilla or connect to another server, which isn't very graceful.
(Assignee)

Comment 1

17 years ago
/quit used to disconnect you from whatever network you issued the command from,
but not exit chatzilla, while /exit disconnected you from all networks *and*
exited chatzilla.  It was impossible to remember which did which (as you can
probably imagine).  So, I renamed /quit to /disconnect, and left /quit to error
with "not implemented".  In retrospect not the best idea, because it leads
people to believe that there is no way to exit the app.  I'll alias quit to exit.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Summary: implement /quit → alias /exit as /quit
(Assignee)

Comment 2

17 years ago
*** Bug 74452 has been marked as a duplicate of this bug. ***

Comment 3

17 years ago
wouldn't it be better to say use if you want to 
disconnect from a server or network please use /disconnect <server/network>
if you want to exit chatzilla (which will disconnect you from all servers and 
dcc connections) please use /exit
(Reporter)

Comment 4

17 years ago
Most clients use /quit to disconnect. It's the standard (well, as standard as
anything is in IRC) method of logging off. It's sort of disconcerting to try to
use it and be confronted with an error, or a message saying that a different
command should be used instead. 

I think /quit should be aliased to /disconnect, myself. On other clients, using
/quit won't cut off your DCC connections, and AFAIK on clients that support
multiple server connections it only disconnects from a single server.
(Reporter)

Comment 5

17 years ago
Changing Platform/OS to All/All. There's nothing about this bug that is
Windows/PC-specific.
OS: Windows NT → All
Hardware: PC → All
(Assignee)

Comment 6

17 years ago
This is fixed in the (upcoming) patch attached to 27805
Depends on: 27805

Comment 7

17 years ago
*** Bug 88730 has been marked as a duplicate of this bug. ***

Comment 8

17 years ago
bug 27805 was committed so this issue is fixed in latest builds
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Product: Core → Other Applications
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.