Firefox takes ~5 minutes to load chromium nightly-builds page (vs. ~15 seconds in Chromium)

RESOLVED DUPLICATE of bug 721730

Status

()

Core
HTML: Parser
RESOLVED DUPLICATE of bug 721730
6 years ago
6 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

6 years ago
STR: 
 [ WARNING: these steps may hang your browser ]

 1. Load http://commondatastorage.googleapis.com/chromium-browser-snapshots/index.html?path=Linux_x64/

 2. On the first "A script on this page may be busy, or it may have stopped responding." prompt, click the "Don't ask me again" button.

ACTUAL RESULTS: Firefox becomes unresponsive with 99% CPU usage for ~5 minutes (on my fairly powerful Ubuntu 64-bit laptop). After that point, it's responsive, but it continues to have > 60% CPU usage.

IN CONTRAST: Chromium has high CPU usage for 10-15 seconds, and then it drops back to its baseline CPU usage level.  (Though occasionally it hits their "aww snap" page instead of the actual folder listing)


Firefox nightly version:
  Mozilla/5.0 (X11; Linux x86_64; rv:14.0) Gecko/20120410 Firefox/14.0a1
Chromium version:
  18.0.1025.151 (Developer Build 130497 Linux) Ubuntu 12.04
All the time is under document.write(), refcounting nsHTMLOwningUTF16Buffer objects in nsHTML5Parser::Parse.

Presumably this is the loop looking for the right insertion point thing that happens when a ton of write() calls are made.  We have existing bugs on that....

Henri, could we please just fix this?  :(
Component: General → HTML: Parser
QA Contact: general → parser
Whiteboard: DUPEME
(Reporter)

Comment 2

6 years ago
Sorry, looks like this is already filed as bug 733597.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
Duplicate of bug: 733597
You need to log in before you can comment on or make changes to this bug.