Last Comment Bug 744611 - Use right compartment iterator when profiling scripts
: Use right compartment iterator when profiling scripts
Status: VERIFIED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla14
Assigned To: Brian Hackett (:bhackett)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-11 15:13 PDT by Brian Hackett (:bhackett)
Modified: 2012-04-13 10:44 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (1.42 KB, patch)
2012-04-11 15:13 PDT, Brian Hackett (:bhackett)
wmccloskey: review+
Details | Diff | Splinter Review

Description Brian Hackett (:bhackett) 2012-04-11 15:13:59 PDT
Created attachment 614191 [details] [diff] [review]
patch

Compartment iteration done during script profiling uses the wrong kind of iterator, which busts asserts in debug builds and causes profiles to be empty in release builds.
Comment 1 Brian Hackett (:bhackett) 2012-04-11 15:55:26 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/93605222dded
Comment 2 :Ms2ger (⌚ UTC+1/+2) 2012-04-12 10:25:58 PDT
https://hg.mozilla.org/mozilla-central/rev/93605222dded
Comment 3 Dan Mosedale (:dmose) 2012-04-13 10:44:20 PDT
Since jit-inspector is now working on today's nightly, I'm going to mark this as verified.  Presumably the AMO can now be told the add-on should work with Fx 14.  Thanks for the quick fix!

Note You need to log in before you can comment on or make changes to this bug.