Lightning doesn't send messages on event updates

RESOLVED DUPLICATE of bug 938459

Status

Calendar
E-mail based Scheduling (iTIP/iMIP)
RESOLVED DUPLICATE of bug 938459
6 years ago
4 years ago

People

(Reporter: Fabricio Machado, Unassigned)

Tracking

Lightning 1.3
x86_64
Windows 7

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/535.2 (KHTML, like Gecko) Chrome/15.0.874.121 Safari/535.2

Steps to reproduce:

1. Create a new event with some atendees and check the 'Send atendees invitation via email' checkbox and save it. Thunderbird asks to send the invitation mail.
2. Modify the event date, or time, or whatever you want and accept.


Actual results:

The new event data are updated, but no invitation mail is sent.


Expected results:

New data should be updated (thats OK) and an invitation with changes should be sent.
(Reporter)

Updated

6 years ago
OS: All → Windows 7
Hardware: All → x86_64

Comment 1

6 years ago
I would like to add that this behaviour is also in Lightning v1.5. I'm running Windows 7 and Thunderbird 13.01. No other add-ons.
(Reporter)

Comment 2

6 years ago
And this last version has an additional problem! You can't even add participants to the event. I updated yesterday and notice this problem. :(

Comment 3

6 years ago
Downgrade to version 1.5.  There is a huge bug in 1.5.1.
(Reporter)

Comment 4

6 years ago
The downgrade to version 1.5.1 has worked and now I can add participants to the event. However, the initial bug reported my me persists.

Comment 5

6 years ago
Indeed, no notifications are sent, neither when creating an event with invitees, nor when accepting invites. I use a CalDav calendar with Cache on.

Error log shows:

Timestamp: 19/09/2012 08:32:45
Error: [Exception... "'TypeError: aItem.calendar.canNotify is not a function' when calling method: [calIOperationListener::onOperationComplete]"  nsresult: "0x8057001c (NS_ERROR_XPC_JS_THREW_JS_OBJECT)"  location: "JS frame :: resource://calendar/modules/calUtils.jsm -> file:///l:/thunderbird/profile/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calCachedCalendar.js :: <TOP_LEVEL> :: line 711"  data: no]
Source File: resource://calendar/modules/calUtils.jsm -> file:///l:/thunderbird/profile/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calCachedCalendar.js
Line: 711

Timestamp: 19/09/2012 08:32:45
Error: [Exception... "'TypeError: aItem.calendar.canNotify is not a function' when calling method: [calIOperationListener::onOperationComplete]"  nsresult: "0x8057001c (NS_ERROR_XPC_JS_THREW_JS_OBJECT)"  location: "JS frame :: resource://calendar/modules/calUtils.jsm -> file:///l:/thunderbird/profile/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calCachedCalendar.js :: <TOP_LEVEL> :: line 711"  data: no]
Source File: resource://calendar/modules/calUtils.jsm -> file:///l:/thunderbird/profile/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calCachedCalendar.js
Line: 711

Timestamp: 19/09/2012 08:32:45
Error: [Exception... "'TypeError: aItem.calendar.canNotify is not a function' when calling method: [calIOperationListener::onOperationComplete]"  nsresult: "0x8057001c (NS_ERROR_XPC_JS_THREW_JS_OBJECT)"  location: "JS frame :: resource://calendar/modules/calUtils.jsm -> file:///l:/thunderbird/profile/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calCachedCalendar.js :: <TOP_LEVEL> :: line 711"  data: no]

Timestamp: 19/09/2012 08:32:46
Error: calendarURI is null
Source File: file:///l:/thunderbird/profile/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calDavCalendar.js
Line: 1136

Comment 6

6 years ago
(In reply to info from comment #5)
You are seeing Bug 788004.

Comment 7

5 years ago
Updating an event does not send updates to atendees, but emails are sent when creating and/or deleting an event.

This is with Thunderbird 16.0.2 and Lightning 1.8.

Updated today to thunderbird 17.0 and Lightning 1.9, the bug persists.

Enabling debugging shows this:

sendXpcomMail: Found USER autoResponse type.
This type is currently unsupported, the compose API will always enter a text/plain
or text/html part as first part of the message.
This will disable OL (up to 2003) to consume the mail as an iTIP invitation showing
the usual calendar buttons.

This bug happens under Windows 7 x86.

Oddly, under Linux (Arch x64) Lightning sends emails when updating an event, just as it should be. this bug apparently only affects Windows clients.

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 938459
You need to log in before you can comment on or make changes to this bug.