Last Comment Bug 744933 - Linux builds of the demo branch of webrtc on alder don't appear to do media
: Linux builds of the demo branch of webrtc on alder don't appear to do media
Status: RESOLVED FIXED
[qa-]
:
Product: Core
Classification: Components
Component: WebRTC (show other bugs)
: Trunk
: All Linux
: -- critical (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks: 731429
  Show dependency treegraph
 
Reported: 2012-04-12 13:38 PDT by [:jesup] on pto until 2016/7/5 Randell Jesup
Modified: 2012-07-27 10:29 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Fix in WebRTC for ALSA deadlock issue on Linux (2.22 KB, patch)
2012-04-19 09:42 PDT, Ethan Hugg [:ehugg]
rjesup: feedback+
snandaku: feedback+
Details | Diff | Review

Description [:jesup] on pto until 2016/7/5 Randell Jesup 2012-04-12 13:38:01 PDT
Ethan had audio but no video, suhas has neither, I have neither.  THey're Ubuntu 11, I'm Fedora 15.
Comment 1 Ethan Hugg [:ehugg] 2012-04-19 09:42:38 PDT
Created attachment 616630 [details] [diff] [review]
Fix in WebRTC for ALSA deadlock issue on Linux
Comment 2 [:jesup] on pto until 2016/7/5 Randell Jesup 2012-04-19 14:20:53 PDT
Let's land this; it might be the cause of Xavier's problem.  Probably it should land on paris_demo and on default.

We should start posting the changeset link when landing a patch (see the tbpl for alder to get the link)
Comment 3 Ethan Hugg [:ehugg] 2012-04-19 14:40:09 PDT
Pushed to both paris_demo and default

default: https://hg.mozilla.org/projects/alder/rev/44e657c163f5
paris_demo: https://hg.mozilla.org/projects/alder/rev/15521dd0a063
Comment 4 [:jesup] on pto until 2016/7/5 Randell Jesup 2012-04-19 14:51:56 PDT
Thanks!

Note You need to log in before you can comment on or make changes to this bug.