Last Comment Bug 744964 - Plugin click-to-play popup notification icon should use the plugin icon, not the add-on icon
: Plugin click-to-play popup notification icon should use the plugin icon, not ...
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: 14 Branch
: All All
: -- normal (vote)
: Firefox 14
Assigned To: Jared Wein [:jaws] (please needinfo? me)
:
Mentors:
Depends on:
Blocks: 711552 743312
  Show dependency treegraph
 
Reported: 2012-04-12 14:40 PDT by Jared Wein [:jaws] (please needinfo? me)
Modified: 2013-04-05 19:16 PDT (History)
7 users (show)
jaws: in‑testsuite-
jaws: in‑litmus-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch for bug (9.23 KB, patch)
2012-04-12 16:59 PDT, Jared Wein [:jaws] (please needinfo? me)
felipc: review+
Details | Diff | Review

Description Jared Wein [:jaws] (please needinfo? me) 2012-04-12 14:40:56 PDT
The click-to-play implementation that landed in bug 711552 used the add-on icon  (puzzle piece) in the doorhangers and popup-notification area.

Since this is directly related to plugins, we should be using the plugin icon (lego block) in both of those locations.

http://mxr.mozilla.org/mozilla-central/source/toolkit/themes/winstripe/mozapps/plugins/pluginGeneric-16.png for reference.
Comment 1 Jim Jeffery not reading bug-mail 1/2/11 2012-04-12 15:21:12 PDT
Click-to-Play Icon also does not have a Tool-tip
Comment 2 Jared Wein [:jaws] (please needinfo? me) 2012-04-12 16:59:18 PDT
Created attachment 614620 [details] [diff] [review]
Patch for bug

Untested on OS X & Linux.

I'll test it on OS X & Linux tomorrow, but the CSS is identical between the platforms so I don't expect any issues ;-)
Comment 3 :Felipe Gomes (needinfo me!) 2012-04-13 00:43:40 PDT
Comment on attachment 614620 [details] [diff] [review]
Patch for bug

So I guess you'll also want to make this change for the icon in about:permissions. Feel free to make it here or in bug 711618, as you prefer.
Comment 4 Jared Wein [:jaws] (please needinfo? me) 2012-04-13 15:03:57 PDT
I'll make the changes to about:permissions in bug 711618.

https://hg.mozilla.org/integration/mozilla-inbound/rev/a038c8c200f5

Note You need to log in before you can comment on or make changes to this bug.