Nightly on Mac OSX -> Segmentation fault 11 (blows on layout)

RESOLVED DUPLICATE of bug 732467

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 732467
6 years ago
6 years ago

People

(Reporter: Dio Synodinos, Unassigned)

Tracking

Other Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:11.0) Gecko/20100101 Firefox/11.0
Build ID: 20120312181643

Steps to reproduce:

1.) hg clone http://hg.mozilla.org/integration/fx-team/

2.) make -f client.mk | tee /tmp/build.log

3.) obj-x86_64-apple-darwin11.3.0/dist/Nightly.app/Contents/MacOS/firefox-bin -purgecaches -P somenewprofile

Build log: http://dl.dropbox.com/u/7060206/fx-build-20120409.log
Error report: http://dl.dropbox.com/u/7060206/error_report.txt


Actual results:

Segmentation fault 11.


Expected results:

Firefox nightly goodness :)
(Reporter)

Comment 1

6 years ago
I wonder why it checks for python 2.7 when it's not a prerequisite and my default python is 2.6.7?
(Reporter)

Updated

6 years ago
Version: Trunk → Other Branch
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 732467
(Reporter)

Updated

6 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 3

6 years ago
Hi Markus, in bug 732467 people seem to suggest that this is an issue with gcc and it works fine with clang. If this is the case, then the current bug is not a duplicate since using gcc doesn't seem to affect anyone else.
Well, it does affect all those who have reported problems in bug 732467, doesn't it?
Have you tested whether using clang works for you?
(Reporter)

Comment 5

6 years ago
(In reply to Markus Stange from comment #4)
> Well, it does affect all those who have reported problems in bug 732467,
> doesn't it?
> Have you tested whether using clang works for you?

Yes you are correct, 

$: cat .mozconfig
export CC=clang
export CXX=clang++
ac_add_options --enable-debug

leads to a successful build.

Does this mean that clang will be the weapon of choice on macs?
> ac_add_options --enable-debug

I hit this bug when I switched from debug to optimized; i.e. a debug build worked on my machine even when building with gcc, but an opt build only worked with clang. So if you've switched both things at the same time be careful not to draw wrong conclusions :)

> Does this mean that clang will be the weapon of choice on macs?

I don't know. The incompatibility with gcc is definitely not intentional; it's probably just a bug in a specific gcc version. I haven't bothered to find out more and any investigations should probably happen in bug 732467.
(Reporter)

Comment 7

6 years ago
(In reply to Markus Stange from comment #6)
> > ac_add_options --enable-debug
> 
> I hit this bug when I switched from debug to optimized; i.e. a debug build
> worked on my machine even when building with gcc, but an opt build only
> worked with clang. So if you've switched both things at the same time be
> careful not to draw wrong conclusions :)

Ok, I'll give gcc+enable-debug a try.

Thanks for the detailed explanation Markus, I appreciate it :)

> > Does this mean that clang will be the weapon of choice on macs?
> 
> I don't know. The incompatibility with gcc is definitely not intentional;
> it's probably just a bug in a specific gcc version. I haven't bothered to
> find out more and any investigations should probably happen in bug 732467.

Yes, marking this as duplicate.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 732467
You need to log in before you can comment on or make changes to this bug.