Last Comment Bug 745149 - Add-on Enter Selects 7 creates zombie compartments and ghost windows since Firefox 13
: Add-on Enter Selects 7 creates zombie compartments and ghost windows since Fi...
Status: RESOLVED FIXED
[MemShrink:P3]
:
Product: Tech Evangelism
Classification: Other
Component: Add-ons (show other bugs)
: unspecified
: x86_64 Windows 7
: -- normal with 2 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
https://addons.mozilla.org/en-US/fire...
Depends on: hueyfix
Blocks: LeakyAddons ZombieCompartments
  Show dependency treegraph
 
Reported: 2012-04-13 04:04 PDT by Loic
Modified: 2012-08-29 20:16 PDT (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Loic 2012-04-13 04:04:41 PDT
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120412 Firefox/14.0a1
Build ID: 20120412030726

Steps to reproduce:

1. Install the add-on Enter Selects 7 (restartless)
https://addons.mozilla.org/en-US/firefox/addon/enter-selects/
2. Open a random image like http://i.imgur.com/9BXQu.jpg
3. Right click on the image and select 'Set As Desktop Background...'
4. Cancel the dialog box
5. Close the tab


Actual results:

Open about:compartments:
URL http://i.imgur.com/9BXQu.jpg is present in 'User Compartments' and 'Ghost Windows' fields.

Open about:memory?verbose:
│   ├─────143,752 B (00.13%) -- compartment(http://i.imgur.com/9BXQu.jpg)
│   │     ├──114,688 B (00.10%) -- gc-heap
│   │     │  ├───55,272 B (00.05%) -- arena
│   │     │  │   ├──54,568 B (00.05%) ── unused
│   │     │  │   ├─────448 B (00.00%) ── headers
│   │     │  │   └─────256 B (00.00%) ── padding
│   │     │  ├───42,920 B (00.04%) -- shapes
│   │     │  │   ├──24,024 B (00.02%) ── dict
│   │     │  │   ├──13,664 B (00.01%) ── base
│   │     │  │   └───5,232 B (00.00%) ── tree
│   │     │  ├───15,616 B (00.01%) -- objects
│   │     │  │   ├──14,016 B (00.01%) ── function
│   │     │  │   └───1,600 B (00.00%) ── non-function
│   │     │  ├──────768 B (00.00%) ── type-objects
│   │     │  └──────112 B (00.00%) ── scripts
│   │     ├───20,864 B (00.02%) -- shapes-extra
│   │     │   ├──10,560 B (00.01%) ── compartment-tables
│   │     │   ├───9,728 B (00.01%) ── dict-tables
│   │     │   ├─────448 B (00.00%) ── tree-tables
│   │     │   └─────128 B (00.00%) ── tree-shape-kids
│   │     ├────8,192 B (00.01%) -- objects
│   │     │    ├──8,064 B (00.01%) ── slots
│   │     │    └────128 B (00.00%) ── misc
│   │     └────────8 B (00.00%) ── script-data

If you disable Enter Selects 7 in the add-on manager (it's restarless), the zombie compartment and the ghost window go away immediately.

The issue is present only in FF13 and FF14.
Comment 1 Loic 2012-04-13 04:18:53 PDT
Add-on maintainer emailed.
Comment 2 Ed Lee :Mardak 2012-04-16 10:10:14 PDT
Doing the STR without installing the add-on results in ghost windows for me.

Ghost Windows
http://i.imgur.com/9BXQu.jpg [2]

│  ├─────183,128 B (00.26%) -- compartment(http://i.imgur.com/9BXQu.jpg)
│  │     ├──139,264 B (00.20%) -- gc-heap
│  │     │  ├───61,040 B (00.09%) -- shapes
│  │     │  │   ├──30,960 B (00.04%) ── dict
│  │     │  │   ├──21,560 B (00.03%) ── base
│  │     │  │   └───8,520 B (00.01%) ── tree
│  │     │  ├───53,048 B (00.08%) -- arena
│  │     │  │   ├──50,912 B (00.07%) ── unused
│  │     │  │   ├───1,088 B (00.00%) ── headers
│  │     │  │   └───1,048 B (00.00%) ── padding
│  │     │  ├───24,016 B (00.03%) -- objects
│  │     │  │   ├──21,952 B (00.03%) ── function
│  │     │  │   └───2,064 B (00.00%) ── non-function
│  │     │  ├────1,008 B (00.00%) ── type-objects
│  │     │  └──────152 B (00.00%) ── scripts
│  │     ├───36,800 B (00.05%) -- shapes-extra
│  │     │   ├──21,248 B (00.03%) ── compartment-tables
│  │     │   ├──14,816 B (00.02%) ── dict-tables
│  │     │   ├─────544 B (00.00%) ── tree-tables
│  │     │   └─────192 B (00.00%) ── tree-shape-kids
│  │     ├────7,056 B (00.01%) -- objects
│  │     │    ├──6,912 B (00.01%) ── slots
│  │     │    └────144 B (00.00%) ── misc
│  │     └────────8 B (00.00%) ── script-data
Comment 3 Justin Lebar (not reading bugmail) 2012-04-16 13:57:42 PDT
> Doing the STR without installing the add-on results in ghost windows for me.

Indeed, bug 734210.

But it's interesting that enter-selects somehow interacts with this.  It's possible that simply disabling a restartless add-on nukes the background-image leak.
Comment 4 Jorge Villalobos [:jorgev] 2012-04-26 15:38:59 PDT
Is there anything that can/should be done for the add-on here? Or is this just a dupe of bug 734210?
Comment 5 Loic 2012-04-26 15:48:14 PDT
As I said previoulsy, I wasn't able to reproduce bug 734210 with the STR given, but only if Enter Selects 7 was enabled. That's why I created this bug, by thinking it was an add-on memory leak.
So maybe you can let it open and we'll check if it's still reproducible when bug 734210 will be fixed.
Comment 6 Loic 2012-04-27 05:47:29 PDT
I tested with a fresh Nightly (Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20120426 Firefox/15.0a1) and I'm not able to reproduce the zombie compartment with Enter Selects 7.
I think it's due to bug 695480.
Comment 7 Justin Lebar (not reading bugmail) 2012-04-27 08:55:21 PDT
\o/
Comment 8 Nicholas Nethercote [:njn] (on vacation until July 11) 2012-04-27 21:14:17 PDT
(In reply to Loic from comment #6)
> I tested with a fresh Nightly (Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0)
> Gecko/20120426 Firefox/15.0a1) and I'm not able to reproduce the zombie
> compartment with Enter Selects 7.
> I think it's due to bug 695480.

I'm going to reopen this.  Firefox 15 will be the first release that has the patch from bug 695480 in it (assuming it doesn't get backed out for some reason).  Firefox 15 won't be released until 2012-08-28, four months from now.  That's plenty of time for leaky add-ons to be fixed or downgraded (and also to degrade users' experience of Firefox).

Once Firefox 15 is out we can close the bugs for any leaky add-ons that bug 695480 fixes.

This means that we can't use Nightly builds to look for add-on leaks in the meantime, which is annoying, but seems unavoidable.
Comment 9 Kyle Huey [:khuey] (khuey@mozilla.com) 2012-04-27 21:20:14 PDT
(In reply to Nicholas Nethercote [:njn] from comment #8)
> I'm going to reopen this.  Firefox 15 will be the first release that has the
> patch from bug 695480 in it (assuming it doesn't get backed out for some
> reason).  Firefox 15 won't be released until 2012-08-28, four months from
> now.  That's plenty of time for leaky add-ons to be fixed or downgraded (and
> also to degrade users' experience of Firefox).
> 
> Once Firefox 15 is out we can close the bugs for any leaky add-ons that bug
> 695480 fixes.

+ Infinity
Comment 10 Nicholas Nethercote [:njn] (on vacation until July 11) 2012-05-02 21:28:05 PDT
(In reply to Loic from comment #6)
> I tested with a fresh Nightly (Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0)
> Gecko/20120426 Firefox/15.0a1) and I'm not able to reproduce the zombie
> compartment with Enter Selects 7.
> I think it's due to bug 695480.

I just confirmed this.  I'd still like to keep this open, as per comment 8.
Comment 11 Nicholas Nethercote [:njn] (on vacation until July 11) 2012-08-29 20:16:47 PDT
The just-released Firefox 15 prevents this leak -- see bug 695480 comment 50.

Note You need to log in before you can comment on or make changes to this bug.