Print button disappears from mail window

RESOLVED WONTFIX

Status

SeaMonkey
UI Design
RESOLVED WONTFIX
5 years ago
5 years ago

People

(Reporter: Rob Janssen, Unassigned)

Tracking

({relnote})

SeaMonkey 2.8 Branch
x86
Windows XP
relnote

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:11.0) Gecko/20120312 Firefox/11.0 SeaMonkey/2.8
Build ID: 20120312220748

Steps to reproduce:

After upgrade from Seamonkey 2.4.1 to 2.8, users complain that print button disappeared.


Actual results:

Users have added a print icon in the toolbar of the mail window.
After upgrading, this icon no longer appears and has to be added again.


Expected results:

Icon should have remained as previously set.
(Reporter)

Comment 1

5 years ago
Checked what happened in localstore.rdf
The buttons shown on the toolbare are stored in "currentset".
The name of the print button has arbitrarily been changed from button-print to print-button, causing it no longer to be recognized by the newer version.
All the other buttons still have a button-xxxxx name.

Please don't make arbitrary changes like this, it just annoys the users.

Updated

5 years ago
Blocks: 676991

Comment 2

5 years ago
Jens, worth a release note?
Keywords: relnote
FTR: Caused by bug 676991 which landed for SM 2.6.

(In reply to Philip Chee from comment #2)
> Jens, worth a release note?

Since I doubt we'll roll back the change (which would cause another round of the problem), I think that's probably all we can do (I won't keep the note forever, though). Otherwise, this bug can be closed.

Checking in seamonkey2.6/index.en.html;
/www/seamonkeyproject-org/src/releases/seamonkey2.6/index.en.html,v  <--  index.en.html
new revision: 1.12; previous revision: 1.11
done
Checking in seamonkey2.7/index.en.html;
/www/seamonkeyproject-org/src/releases/seamonkey2.7/index.en.html,v  <--  index.en.html
new revision: 1.6; previous revision: 1.5
done
Checking in seamonkey2.8/index.en.html;
/www/seamonkeyproject-org/src/releases/seamonkey2.8/index.en.html,v  <--  index.en.html
new revision: 1.8; previous revision: 1.7
done

[If anyone feels strongly about also including the note in the SM 2.9 or later relnotes, let me know. Otherwise it'll only be the above three relnotes which will include the note.]
Whiteboard: [CLOSEME WONTFIX?]

Updated

5 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

5 years ago
Resolved per whiteboard
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
Whiteboard: [CLOSEME WONTFIX?]
You need to log in before you can comment on or make changes to this bug.