Closed Bug 745245 Opened 10 years ago Closed 10 years ago

android.database.sqlite.SQLiteDatabaseLockedException: database is locked at android.database.sqlite.SQLiteStatement.native_executeSql(Native Method)

Categories

(Firefox for Android Graveyard :: General, defect)

14 Branch
ARM
Android
defect
Not set
critical

Tracking

(blocking-fennec1.0 beta+)

RESOLVED DUPLICATE of bug 741224
Tracking Status
blocking-fennec1.0 --- beta+

People

(Reporter: scoobidiver, Unassigned)

Details

(Keywords: crash, Whiteboard: [native-crash])

Crash Data

It was hit by one user: bp-db56c733-0c66-48f8-90ec-b7f642120413.

android.database.sqlite.SQLiteDatabaseLockedException: database is locked
	at android.database.sqlite.SQLiteStatement.native_executeSql(Native Method)
	at android.database.sqlite.SQLiteStatement.executeUpdateDelete(SQLiteStatement.java:90)
	at android.database.sqlite.SQLiteDatabase.executeSql(SQLiteDatabase.java:2025)
	at android.database.sqlite.SQLiteDatabase.execSQL(SQLiteDatabase.java:1965)
	at android.database.sqlite.SQLiteDatabase.beginTransaction(SQLiteDatabase.java:690)
	at android.database.sqlite.SQLiteDatabase.beginTransaction(SQLiteDatabase.java:581)
	at org.mozilla.fennec.db.BrowserProvider.update(BrowserProvider.java:1324)
	at android.content.ContentProvider$Transport.update(ContentProvider.java:219)
	at android.content.ContentResolver.update(ContentResolver.java:856)
	at org.mozilla.gecko.db.LocalBrowserDB.updateVisitedHistory(LocalBrowserDB.java:259)
	at org.mozilla.gecko.db.BrowserDB.updateVisitedHistory(BrowserDB.java:125)
	at org.mozilla.gecko.GlobalHistory.add(GlobalHistory.java:119)
	at org.mozilla.gecko.Tab$7.run(Tab.java:487)
	at android.os.Handler.handleCallback(Handler.java:605)
	at android.os.Handler.dispatchMessage(Handler.java:92)
	at android.os.Looper.loop(Looper.java:137)
	at org.mozilla.gecko.GeckoBackgroundThread.run(GeckoBackgroundThread.java:31)

More reports at:
https://crash-stats.mozilla.com/report/list?signature=android.database.sqlite.SQLiteDatabaseLockedException%3A+database+is+locked+at+android.database.sqlite.SQLiteStatement.native_executeSql%28Native+Method%29
blocking-fennec1.0: --- → ?
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 741224
blocking-fennec1.0: ? → beta+
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.