Make RDF parser for addon details namespace aware

RESOLVED DUPLICATE of bug 651212

Status

RESOLVED DUPLICATE of bug 651212
7 years ago
7 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mozmill-2.0+])

Given bug 622808 we fail in a couple of situations to get details for add-ons which do not follow the em: namespace. Right now it's hard-coded and breaks for any other namespace.

For our automation scripts we have created two helper methods which help us to get the proper namespace and the value of elements:

http://hg.mozilla.org/qa/mozmill-automation/file/default/libs/rdf_parser.py

Given that we will refactor our code soon Dave, David, or me can take care of this work. Flagging for Mozmill 2 because it would help us to centralize our code.
An example of a still broken extension is Mnenhy:
https://addons.mozilla.org/thunderbird/addon/mnenhy/
As discussed in the auto-tools meeting this module has to be included into mozprofile for a correct handling of RDF files.

Comment 3

7 years ago
Mozprofile does handle some of the namespacing stuff here. I'm not sure if it does everything we need. But we should take this and figure out if there is any other action required.

See: https://github.com/mozilla/mozbase/blob/master/mozprofile/mozprofile/addons.py#L119
Whiteboard: [mozmill-2.0?] → [mozmill-2.0+]

Comment 4

7 years ago
Aha, Henrik and I figured out we *did* already do this.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 651212
You need to log in before you can comment on or make changes to this bug.