Last Comment Bug 745426 - Maintenance service description should wrap to allow long localizations
: Maintenance service description should wrap to allow long localizations
Status: RESOLVED FIXED
[qa+]
:
Product: Firefox
Classification: Client Software
Component: Installer (show other bugs)
: Trunk
: x86 Windows 7
: -- normal with 1 vote (vote)
: Firefox 13
Assigned To: Robert Strong [:rstrong] (use needinfo to contact me)
:
:
Mentors:
: 747711 747714 (view as bug list)
Depends on:
Blocks: 481815
  Show dependency treegraph
 
Reported: 2012-04-14 01:06 PDT by Francesco Lodolo [:flod]
Modified: 2012-08-03 01:16 PDT (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
affected
+
verified
+
verified
+
verified
unaffected
unaffected


Attachments
Screnshot of Italian installer (12b4) (36.87 KB, image/png)
2012-04-14 01:06 PDT, Francesco Lodolo [:flod]
no flags Details
Firefox 12 Setup with the truncated German text (44.43 KB, image/png)
2012-04-22 09:57 PDT, André Ziegler
no flags Details
Same problem in Russian installer (27.93 KB, image/png)
2012-04-22 10:02 PDT, Alexander L. Slovesnik
no flags Details
patch rev1 - extend label to accommodate text (1.81 KB, text/plain)
2012-05-21 14:55 PDT, Robert Strong [:rstrong] (use needinfo to contact me)
no flags Details
screenshots with fix (65.49 KB, image/png)
2012-05-21 16:14 PDT, Robert Strong [:rstrong] (use needinfo to contact me)
no flags Details
patch rev2 - extend label to accommodate text (1.81 KB, patch)
2012-05-21 16:16 PDT, Robert Strong [:rstrong] (use needinfo to contact me)
netzen: review+
akeybl: approval‑mozilla‑aurora+
akeybl: approval‑mozilla‑beta+
Details | Diff | Splinter Review
Firefox 13 Setup with the complete German text (32.23 KB, image/png)
2012-05-24 08:46 PDT, André Ziegler
no flags Details

Description Francesco Lodolo [:flod] 2012-04-14 01:06:14 PDT
Created attachment 615015 [details]
Screnshot of Italian installer (12b4)

Current Italian localization of OPTIONAL_COMPONENTS_DESC is "Il servizio di manutenzione consente di installare gli aggiornamenti di $BrandShortName senza bisogno di interventi da parte dell'utente.", which should be around 130 characters. The result is shown in the attachment: the string is cut before character #100

According to notes in installer/custom.properties I can't add a new line on my locale.
"You can use \n to create a newline in the string but only when the string from en-US contains a \n."

Is it possible to make that line wrap? I can try to shorten that string somehow, but the resulting translation would be less clear for users (and that's an important piece of information). I also suspect that this issue involves other locales, not only Italian (maybe German and French, they're around 100 characters long).
Comment 1 Francesco Lodolo [:flod] 2012-04-22 00:50:45 PDT
*** Bug 747711 has been marked as a duplicate of this bug. ***
Comment 2 André Ziegler 2012-04-22 09:56:05 PDT
I have the same "issue" with the German setup.
Comment 3 André Ziegler 2012-04-22 09:57:42 PDT
Created attachment 617326 [details]
Firefox 12 Setup with the truncated German text

Firefox 12 Setup with the truncated German text
Comment 4 Alexander L. Slovesnik 2012-04-22 10:02:43 PDT
Created attachment 617327 [details]
Same problem in Russian installer
Comment 5 Matthias Versen [:Matti] 2012-04-22 17:32:16 PDT
*** Bug 747714 has been marked as a duplicate of this bug. ***
Comment 6 Robert Strong [:rstrong] (use needinfo to contact me) 2012-05-21 14:55:48 PDT
Created attachment 625775 [details]
patch rev1 - extend label to accommodate text

I need to check the UI so holding off on requesting review until after I have done this.
Comment 7 Robert Strong [:rstrong] (use needinfo to contact me) 2012-05-21 16:14:24 PDT
Created attachment 625812 [details]
screenshots with fix
Comment 8 Robert Strong [:rstrong] (use needinfo to contact me) 2012-05-21 16:16:06 PDT
Created attachment 625813 [details] [diff] [review]
patch rev2 - extend label to accommodate text

This should be sufficient
Comment 9 Brian R. Bondy [:bbondy] 2012-05-21 16:42:28 PDT
Comment on attachment 625813 [details] [diff] [review]
patch rev2 - extend label to accommodate text

Thanks for taking this, looks good.
Comment 10 Robert Strong [:rstrong] (use needinfo to contact me) 2012-05-21 17:04:38 PDT
Pushed to fx-team
https://hg.mozilla.org/integration/fx-team/rev/21be0265c5f3

Adding tracking flags.

Drivers, this causes locales with longer than en-US text to have the text cut-off for the description of the maintenance service in the installer. It is only shown during a custom installation.
Comment 11 Robert Strong [:rstrong] (use needinfo to contact me) 2012-05-21 17:06:46 PDT
Comment on attachment 625813 [details] [diff] [review]
patch rev2 - extend label to accommodate text

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 481815
User impact if declined: When installing the text in the installer is not displayed on some locales.
Testing completed (on m-c, etc.): Tested locally
Risk to taking this patch (and alternatives if risky): Low Risk
String or UUID changes made by this patch: None

Note: I am ok with not taking this but it is extremely low risk and the UX without it is very bad / unprofessional.
Comment 12 Tim Taubert [:ttaubert] 2012-05-22 06:22:46 PDT
https://hg.mozilla.org/mozilla-central/rev/21be0265c5f3
Comment 13 André Ziegler 2012-05-22 08:29:32 PDT
any chance to also land this for beta and aurora?
Comment 14 Brian R. Bondy [:bbondy] 2012-05-22 08:41:49 PDT
> any chance to also land this for beta and aurora?

Beta and Aurora have been requested in Comment 11, release drivers will make a decision soon and update the bug.
Comment 15 André Ziegler 2012-05-22 08:47:52 PDT
ok, thanks :)
Comment 16 Alex Keybl [:akeybl] 2012-05-22 11:13:47 PDT
Comment on attachment 625813 [details] [diff] [review]
patch rev2 - extend label to accommodate text

[Triage Comment]
Approved for Aurora 14. If landed today, thus making it into FF13beta5, also approved for Beta 13.
Comment 17 Brian R. Bondy [:bbondy] 2012-05-22 11:20:02 PDT
I'll land it for Rob now in both
Comment 19 Robert Strong [:rstrong] (use needinfo to contact me) 2012-05-22 12:08:15 PDT
Thanks for landing this Brian!
Comment 20 André Ziegler 2012-05-24 08:45:46 PDT
ok, fix is part of Firefox 13b5 and works fine. Now I can read the complete text :)
Comment 21 André Ziegler 2012-05-24 08:46:53 PDT
Created attachment 626826 [details]
Firefox 13 Setup with the complete German text
Comment 22 Robert Kaiser 2012-05-24 11:04:35 PDT
(In reply to André Ziegler from comment #21)
> Created attachment 626826 [details]
> Firefox 13 Setup with the complete German text

Thanks for tracking and testing this and to Francesco for reporting it in the first place!
Comment 23 Simona B [:simonab ] 2012-05-30 07:11:45 PDT
Did the text in some of the locals changed? For e.g the text on the Italian Installer is different between Firefox 12 beta 5 and Firefox 13 beta 6.
Comment 24 Simona B [:simonab ] 2012-05-31 02:22:53 PDT
Verified using Firefox 13 beta 6 on Windows 7 and on Windows XP that the text from the Installer that refers to the Maintenance service is complete. 

Verified on the following locals: de, ru, it and fr.
Build-Identifikator: Mozilla/5.0 (Windows NT 6.1; rv:13.0) Gecko/20100101 Firefox/13.0
Идентификатор сборки: Mozilla/5.0 (Windows NT 6.1; rv:13.0) Gecko/20100101 Firefox/13.0
Identificativo build: Mozilla/5.0 (Windows NT 6.1; rv:13.0) Gecko/20100101 Firefox/13.0
Identifiant de compilation : Mozilla/5.0 (Windows NT 6.1; rv:13.0) Gecko/20100101 Firefox/13.0
Идентификатор сборки: Mozilla/5.0 (Windows NT 6.1; rv:13.0) Gecko/20100101 Firefox/13.0
Comment 25 Simona B [:simonab ] 2012-06-18 08:38:59 PDT
Verified using Firefox 14 beta 7 on Windows XP and on Windows 7 that the text from the Installer that refers to the Maintenance service is complete.

Verified on the locals: de, fr, it and ru:

Build-Identifikator: Mozilla/5.0 (Windows NT 5.1; rv:14.0) Gecko/20100101 Firefox/14.0
Build-Identifikator: Mozilla/5.0 (Windows NT 6.1; rv:14.0) Gecko/20100101 Firefox/14.0

Identifiant de compilation : Mozilla/5.0 (Windows NT 5.1; rv:14.0) Gecko/20100101 Firefox/14.0
Identifiant de compilation : Mozilla/5.0 (Windows NT 6.1; rv:14.0) Gecko/20100101 Firefox/14.0

Identificativo build: Mozilla/5.0 (Windows NT 5.1; rv:14.0) Gecko/20100101 Firefox/14.0
Identificativo build: Mozilla/5.0 (Windows NT 6.1; rv:14.0) Gecko/20100101 Firefox/14.0

Идентификатор сборки: Mozilla/5.0 (Windows NT 5.1; rv:14.0) Gecko/20100101 Firefox/14.0
Идентификатор сборки: Mozilla/5.0 (Windows NT 6.1; rv:14.0) Gecko/20100101 Firefox/14.0
Comment 26 Simona B [:simonab ] 2012-08-03 01:16:19 PDT
Verified on Win XP and on Win 7 using Firefox 15 beta 3 that - the text from the installer that refers to the Mozilla Maintenance Service is complete. Verified on several locals: de, fr, it and ru.

Build-Identifikator: Mozilla/5.0 (Windows NT 5.1; rv:15.0) Gecko/20100101 Firefox/15.0
Build-Identifikator: Mozilla/5.0 (Windows NT 6.1; rv:15.0) Gecko/20100101 Firefox/15.0

Identifiant de compilation : Mozilla/5.0 (Windows NT 5.1; rv:15.0) Gecko/20100101 Firefox/15.0
Identifiant de compilation : Mozilla/5.0 (Windows NT 6.1; rv:15.0) Gecko/20100101 Firefox/15.0

Identificativo build: Mozilla/5.0 (Windows NT 5.1; rv:15.0) Gecko/20100101 Firefox/15.0
Identificativo build: Mozilla/5.0 (Windows NT 6.1; rv:15.0) Gecko/20100101 Firefox/15.0

Идентификатор сборки: Mozilla/5.0 (Windows NT 5.1; rv:15.0) Gecko/20100101 Firefox/15.0
Идентификатор сборки: Mozilla/5.0 (Windows NT 6.1; rv:15.0) Gecko/20100101 Firefox/15.0

Note You need to log in before you can comment on or make changes to this bug.