XML served as application/octet-stream results in misleading error message

VERIFIED DUPLICATE of bug 74510

Status

SeaMonkey
General
VERIFIED DUPLICATE of bug 74510
17 years ago
12 years ago

People

(Reporter: steve.swanson, Assigned: asa)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; 0.8.1) Gecko/20010323
BuildID:    2001032319

The message says: "This file has mime type text/xml and cannot be viewed using
Mozilla. ..."  But Mozilla can view files with this mime type.  Something else
has gone wrong.

Reproducible: Always
Steps to Reproduce:
1. Open http://www.hipnt.com/MathML/smallsampleout.xml
2. Read the error message.


Actual Results:  Mozilla refuses to open the URL.

Expected Results:  A. Post a more meaningful error message.
B. You could actually open the stream as XML (since the extension is xml), but
that might be risky.

Note that I will probably change the server www.hipnt.com so that is serves XML
files as text/xml in the near future.  But it's easy enough to change your own
server to reproduce the bug.
Yeah... This was a "good idea" someone had that got implemented kinda poorly..

*** This bug has been marked as a duplicate of 74510 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
vrfy dupe
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.