Last Comment Bug 745447 - XUL progress meter layout should match HTML
: XUL progress meter layout should match HTML
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XUL (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: neil@parkwaycc.co.uk
:
Mentors:
Depends on:
Blocks: 658829
  Show dependency treegraph
 
Reported: 2012-04-14 06:47 PDT by neil@parkwaycc.co.uk
Modified: 2012-04-27 01:17 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Proposed patch (3.19 KB, patch)
2012-04-14 06:51 PDT, neil@parkwaycc.co.uk
enndeakin: review+
Details | Diff | Splinter Review

Description neil@parkwaycc.co.uk 2012-04-14 06:47:13 PDT
In bug 658829 jimm was easily able to animate the HTML undetermined progress meter because in that mode the progress chunk is sized to fill the meter. He wanted to apply his animation to the default themed XUL progressmeter as well but XUL layout doesn't special-case undetermined meters. I suppose the choice is between creating an extra XBL binding that just contains a full progress chunk or altering XUL layout so that the normal binding will create a full chunk. Either way the widget code can then animate it as per the HTML meter.
Comment 1 neil@parkwaycc.co.uk 2012-04-14 06:51:03 PDT
Created attachment 615043 [details] [diff] [review]
Proposed patch
Comment 2 neil@parkwaycc.co.uk 2012-04-27 01:17:15 PDT
Pushed changeset 450d8cd16316 to mozilla-central.

Note You need to log in before you can comment on or make changes to this bug.