Note: There are a few cases of duplicates in user autocompletion which are being worked on.

test_location.html fails if it is executed alone

RESOLVED FIXED in mozilla15

Status

()

Core
DOM: Workers
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: emk, Assigned: emk)

Tracking

Trunk
mozilla15
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

2.19 KB, patch
Ben Turner (not reading bugmail, use the needinfo flag!)
: review+
Details | Diff | Splinter Review
(Assignee)

Description

5 years ago
Steps to reproduce:
$ make -C obj-i686-pc-mingw32/dom/workers/test && TEST_PATH=dom/workers/test/test_location.html make -C obj-i686-pc-mingw32 mochitest-plain

Actual result:
failed | Correct filename - got test_location.html, expected
failed | undefined - got http://mochi.test:8888/tests/dom/workers/test/location_worker.js, expected http://mochi.test:8888/tests/dom/workers/test/test_location.html?autorun=1&closeWhenDone=1&logFile=h%3A%5Cmozdev%5Cmozilla-central%5Cobj-i686-pc-mingw32%5Cmochitest-plain.log&fileLevel=INFO&consoleLevel=INFO&failureFile=h:/mozdev/mozilla-central/obj-i686-pc-mingw32/_tests/testing/mochitest/location_worker.js
failed | undefined - got http://mochi.test:8888/tests/dom/workers/test/location_worker.js, expected http://mochi.test:8888/tests/dom/workers/test/test_location.html?autorun=1&closeWhenDone=1&logFile=h%3A%5Cmozdev%5Cmozilla-central%5Cobj-i686-pc-mingw32%5Cmochitest-plain.log&fileLevel=INFO&consoleLevel=INFO&failureFile=h:/mozdev/mozilla-central/obj-i686-pc-mingw32/_tests/testing/mochitest/location_worker.js

If the test is executed along with other worker tests, it doesn't fail. (So tinderbox can't catch this)
(Assignee)

Comment 1

5 years ago
Created attachment 615109 [details] [diff] [review]
patch

The test failed if the query contained "/".
I also added event.data.string as a test message because "undefined" didn't help at all to find out what caused the bug.
Attachment #615109 - Flags: review?(bent.mozilla)
Attachment #615109 - Flags: review?(bent.mozilla) → review+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed

Updated

5 years ago
Assignee: nobody → VYV03354
https://hg.mozilla.org/integration/mozilla-inbound/rev/e77b0d6fd34a
Flags: in-testsuite+
Keywords: checkin-needed
Target Milestone: --- → mozilla15
https://hg.mozilla.org/mozilla-central/rev/e77b0d6fd34a
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.