Last Comment Bug 745542 - Remove support for font-weight and point-size attributes on the font element
: Remove support for font-weight and point-size attributes on the font element
Status: RESOLVED FIXED
: dev-doc-complete
Product: Core
Classification: Components
Component: DOM: Core & HTML (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla15
Assigned To: :Ms2ger (⌚ UTC+1/+2)
:
: Andrew Overholt [:overholt]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-15 07:06 PDT by :Ms2ger (⌚ UTC+1/+2)
Modified: 2012-05-07 09:06 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (3.93 KB, patch)
2012-04-15 07:33 PDT, :Ms2ger (⌚ UTC+1/+2)
jonas: review+
Details | Diff | Splinter Review

Description :Ms2ger (⌚ UTC+1/+2) 2012-04-15 07:06:54 PDT
Because, I mean, come on! Only supported in Gecko, and the only reference I can find on the web is <http://www.idocs.com/tags/_FONT_POINT-SIZE.html>, which thinks 'font-weight' is called 'weight'.
Comment 1 :Ms2ger (⌚ UTC+1/+2) 2012-04-15 07:33:51 PDT
Created attachment 615154 [details] [diff] [review]
Patch v1
Comment 2 Jonas Sicking (:sicking) No longer reading bugmail consistently 2012-04-25 03:49:47 PDT
Comment on attachment 615154 [details] [diff] [review]
Patch v1

Review of attachment 615154 [details] [diff] [review]:
-----------------------------------------------------------------

Remove pointSize from nsGkAtoms too
Comment 3 :Ms2ger (⌚ UTC+1/+2) 2012-04-26 10:52:27 PDT
(In reply to Jonas Sicking (:sicking) from comment #2)
> Comment on attachment 615154 [details] [diff] [review]
> Patch v1
> 
> Review of attachment 615154 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Remove pointSize from nsGkAtoms too

Used in nsTreeSanitizer. Henri?
Comment 5 :Ms2ger (⌚ UTC+1/+2) 2012-05-05 10:26:25 PDT
https://hg.mozilla.org/mozilla-central/rev/5736136d350c
Comment 6 Eric Shepherd [:sheppy] 2012-05-07 09:06:44 PDT
Documented:

https://developer.mozilla.org/en/HTML/Element/font#Gecko_notes

Mentioned on Firefox 15 for developers.

Note You need to log in before you can comment on or make changes to this bug.