Closed Bug 745543 Opened 8 years ago Closed 8 years ago

Back ground color does not work on Rich Text Editor Demo http://www-archive.mozilla.org/editor/midasdemo/

Categories

(Core :: DOM: Editor, defect)

14 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 279330

People

(Reporter: alice0775, Unassigned)

References

()

Details

(Keywords: regression)

Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/0d871550085e
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120415 Firefox/14.0a1 ID:20120415030725

Background color does not work on Rich Text Editor Demo http://www-archive.mozilla.org/editor/midasdemo/.
This may be TE.

Reproducible: Always

Steps to reproduce:
1. Open http://www-archive.mozilla.org/editor/midasdemo/
2. Type any text
3. Select some text
4. Click Background-color Icon and choose color
5. Click else where

Actual results:
  Background color does not work

Expected results:
  Background color should work

Regression window(m-c):
Works:
http://hg.mozilla.org/mozilla-central/rev/6881fa89cfca
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120404 Firefox/14.0a1 ID:20120404001322
Fails:
http://hg.mozilla.org/mozilla-central/rev/
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120404 Firefox/14.0a1 ID:20120404043722
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=6881fa89cfca&tochange=638769f8ec54

Regression window(m-i):
Works:
http://hg.mozilla.org/integration/mozilla-inbound/rev/679211c94743
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120403 Firefox/14.0a1 ID:20120403053722
Fails:
http://hg.mozilla.org/integration/mozilla-inbound/rev/cfcdf9a80f36
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120403 Firefox/14.0a1 ID:20120403071722
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=679211c94743&tochange=cfcdf9a80f36
Suspected
aaba08c21296	Aryeh Gregor — Bug 738366 - Default styleWithCSS to false; r=ehsan
This works in my patched build.  It should be fixed when bug 279330 lands.
http://www.kevinroth.com/rte/demo.htm is also affected
Also works fine in my build.  I should hopefully be able to land bug 279330 tonight or tomorrow my time, if I get r+ (that's tonight or tomorrow night American time).
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 279330
You need to log in before you can comment on or make changes to this bug.