Last Comment Bug 745723 - Only store known fails in currentStatus.js for richtext2, like for richtext
: Only store known fails in currentStatus.js for richtext2, like for richtext
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Editor (show other bugs)
: Trunk
: All All
: -- enhancement (vote)
: mozilla15
Assigned To: :Aryeh Gregor (away until August 15)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-16 06:02 PDT by :Aryeh Gregor (away until August 15)
Modified: 2012-04-24 17:57 PDT (History)
1 user (show)
ayg: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (1.28 MB, patch)
2012-04-17 04:31 PDT, :Aryeh Gregor (away until August 15)
ehsan: review+
Details | Diff | Review

Description :Aryeh Gregor (away until August 15) 2012-04-16 06:02:34 PDT
currentStatus.js for richtext only stores known fails.  This way, if a known fail becomes a pass, you can just delete the line from currentStatus.js.  For richtext2, it stores data for all tests, so a) it's much more cumbersome to update if you fix bugs; b) it's impossible to tell from the diff whether the change to currentStatus.js adds new expected failures or only changes/removes them; and c) it makes merge conflicts hard to impossible to resolve by hand.

We only look at .selScore, .valScore, and .output.  I'm not sure we really need to use .output -- the tests are very self-explanatory if you look at the webpage.  I've never had to use it.

Ehsan, would it be okay with you if instead of the TEST_RESULTS object, I make two objects called knownSelFailures and knownValFailures and drop the .output stuff?  So it will give the test name on failure but no actual/expected values.  Alternatively, I could maintain a third object with the actual/expected values for everything, if we want that too.
Comment 1 :Aryeh Gregor (away until August 15) 2012-04-17 04:31:59 PDT
Created attachment 615663 [details] [diff] [review]
Patch v1

Diffstat:


 editor/libeditor/html/tests/browserscope/lib/richtext2/currentStatus.js |  26317 ++--------------------
 editor/libeditor/html/tests/browserscope/test_richtext2.html            |     71 +-
 2 files changed, 2506 insertions(+), 23882 deletions(-)

This would be great for me, because I wouldn't have to make all my richtext2-affecting patches depend on each other.
Comment 2 :Ehsan Akhgari (out sick) 2012-04-17 13:21:19 PDT
Comment on attachment 615663 [details] [diff] [review]
Patch v1

Review of attachment 615663 [details] [diff] [review]:
-----------------------------------------------------------------

I'd take any patches which make your life easier in a heartbeat!  :-)
Comment 3 :Aryeh Gregor (away until August 15) 2012-04-18 07:27:52 PDT
http://hg.mozilla.org/projects/birch/rev/69508abaf5d0
Comment 4 :Ehsan Akhgari (out sick) 2012-04-24 17:57:49 PDT
https://hg.mozilla.org/mozilla-central/rev/69508abaf5d0

Note You need to log in before you can comment on or make changes to this bug.