Last Comment Bug 745746 - Magic screen reader issue
: Magic screen reader issue
Status: RESOLVED FIXED
: access
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks: tbirda11y
  Show dependency treegraph
 
Reported: 2012-04-16 07:57 PDT by David Weir (satdav)
Modified: 2012-07-17 02:16 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description David Weir (satdav) 2012-04-16 07:57:04 PDT
posting on behalf of someone 


I am Blind and use assistive technology with Thunderbird. The program I use is Zoom Text. I have also used Magic.

Is there any talk that Thunderbird will be able to play with Zoom Text or any other assisitive technology software? Thunderbird does not like these types of software and is getting to be so discouraging, I aqm forced to go over to the "dark side" (MS products).

I have always liked Mozilla software (I'm an old Netscape fan) and do not want to leave.

AI2 and Freedom Scientific tech support have told me the same thing that Thunderbird uses a lot of scripting code that their software does not recognize. They both have written the AT software for MS products....ant glimpse in the future about this? . 

I can not duplicate the issue using a web based system. It only effects Thunderbird. Using this type of format (Reply to this topic), does not work with the AT Software. I have it magnified to the max in order to type this out. I have copied what I sent you yesterday:

David, thanks for the response. This e-mail will show you how Thunderbird reacts with the AT software. As I am typing, one of the things you don't see is the cursor bar that AT software use to help locate the cursor and move the screen, now you also see how the font size and type have changed. (the default is Tahoma and x-large)This is caused by going back in the sentence structure and correcting a word or phrase. Getting back to the cursor bar, it also moves the screen so that you can see what your typing. With AT software, the screen is much larger than the monitor so it uses the bar to move the image on the screen so that you can see beyond the constrains of the monitor. Mine is not a severe as some people that I know. I use use a image 2x of the screen display. A lot of people use higher magnification, such as 5x.

Hope this helps you a little. The techs have said that after Thunderbird 3 and Firefox4, code changed and they have not been able to fix the software......Yes, there are some problems with Firefox also, but they are just nuisances (video does not play in Firefox) and sometimes if the page does not display correctly.....I am forced to use IE.

Thanks once again for even looking into this. If this can ever get fixed, I know a lot of folks that would migrate back to Mozilla. Sincerely, Bryan Gearry

Copying this to the web, changed the font and format. Now you can not see what is happening.
Comment 1 David Bolter [:davidb] 2012-04-16 07:59:57 PDT
cc+ Jost
Comment 2 Jost Eckhardt, Ai Squared 2012-04-16 10:46:55 PDT
Does Thunderbird 3 and later use D2D?

Is it possible to turn hardware acceleration off?
Comment 3 David Bolter [:davidb] 2012-04-16 10:51:55 PDT
It should be an option in about:config. I'd like to sort out a solution that works with D2D though...
Comment 4 David Weir (satdav) 2012-04-16 15:18:06 PDT
but for people who do not know how to use about config would be good for it to be enbled by default
Comment 5 Jost Eckhardt, Ai Squared 2012-04-17 04:57:35 PDT
I believe we have a fix for the cursor tracking and enhancements. We are testing it right now and it will be in the next update of ZoomText.
Comment 6 alexander :surkov 2012-04-17 05:05:51 PDT
(In reply to Jost Eckhardt, Ai Squared from comment #5)
> I believe we have a fix for the cursor tracking and enhancements. We are
> testing it right now and it will be in the next update of ZoomText.

does it make sense to keep the bug open until you release?
Comment 7 Jost Eckhardt, Ai Squared 2012-04-17 05:07:48 PDT
I guess, best would be if the user could confirm that the fix works. I will post as soon as the update is released
Comment 8 alexander :surkov 2012-04-17 05:09:02 PDT
(In reply to Jost Eckhardt, Ai Squared from comment #7)
> I guess, best would be if the user could confirm that the fix works. I will
> post as soon as the update is released

ok, thank you
Comment 9 David Weir (satdav) 2012-04-26 15:17:29 PDT
Hi their can we get a update on if its been fixed yet as it would be good for this as soon as possible
Comment 10 Jost Eckhardt, Ai Squared 2012-06-13 09:16:08 PDT
For ZoomText Thunderbird support has been fixed in 10.0.3 - http://www.aisquared.com/news/more/zoomtext_1003_is_released/
Comment 11 David Weir (satdav) 2012-07-17 02:16:35 PDT
Fixed

Note You need to log in before you can comment on or make changes to this bug.