If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Successful frame-busting with latest gecko

RESOLVED WORKSFORME

Status

()

Core
DOM: Core & HTML
RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: cjones, Unassigned)

Tracking

(Blocks: 1 bug, {dogfood})

Trunk
x86_64
Linux
dogfood
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

STR
 (1) Load http://mednet.ucla.edu/
 (2) Click on the "Mednet E-Mail" button in the top right

The browser freezes up for a second or so while the page loads, then BAM, it busts all the way out to replace the homescreen frame.  I thought we were supposed to be preventing that.

This might be timing sensitive ... I can reliably reproduce on the sgs2 following the steps above.  However, if I go directly to the linked URL (https://mail.mednet.ucla.edu/exchange) I don't see the framebusting.  Going to try on another phone.
Keywords: dogfood
Ouch, yes, we're supposed to be preventing that, modulo bug 740479, which I somehow doubt is at play here.

I'm at a MemShrink meeting this week, but I'll look at this when I get back.
Interestingly, it doesn't seem to be bug 740479.

I don't think this is worth spending a lot of time on atm.  It should be fixed definitively by OOP mozbrowser.
Just tested, seems to work fine with OOP browser.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.