Date.prototype.toISOString not using extended years ala ES5 spec

RESOLVED DUPLICATE of bug 730831

Status

()

RESOLVED DUPLICATE of bug 730831
6 years ago
6 years ago

People

(Reporter: roger.andrews, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0
Build ID: 20120312181643

Steps to reproduce:

(new Date(999999999999999)).toISOString()


Actual results:

Result was "33658-09-27T01:46:39.999Z"


Expected results:

Result should be "+033658-09-27T01:46:39.999Z"
(i.e. using signed 6-digit extended years)
according to ES5 spec section 15.9.1.15.1

Similar spec variance happens with a large negative year;
and indeed with any year outside 0000-9999.
(Reporter)

Updated

6 years ago
Component: General → JavaScript Engine
(Reporter)

Comment 1

6 years ago
Same issue as:
Bug 730831 - Date.prototype.toISOString returns not a valid ISO-8601 string
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 730831
You need to log in before you can comment on or make changes to this bug.