Note: There are a few cases of duplicates in user autocompletion which are being worked on.

IonMonkey: Assertion failure: unexpected type, at ion/Lowering.cpp:822

RESOLVED FIXED

Status

()

Core
JavaScript Engine
--
major
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: decoder, Assigned: djvj)

Tracking

(Blocks: 2 bugs, {assertion, testcase})

Other Branch
x86_64
Linux
assertion, testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [jsbugmon:update,reconfirm,ignore])

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

5 years ago
The following testcase asserts on ionmonkey revision 67bf9a4a1f77 (run with --ion -n -m --ion-eager):


(function () {
  var a = ['x', 'y'];
  obj.watch(a[+("0")], counter);
})();
(Reporter)

Comment 1

5 years ago
JSBugMon: The testcase found in this bug no longer reproduces (tried revision de015aff650d).
(Reporter)

Updated

5 years ago
Whiteboard: [jsbugmon:update] → [jsbugmon:update,ignore]
(Reporter)

Comment 2

5 years ago
The test here broke because bug
Whiteboard: [jsbugmon:update,ignore] → [jsbugmon:update,reconfirm]
(Reporter)

Comment 3

5 years ago
Yea.. because bug...  because bug 724751 removed the --ion, -n and -m options. It probably would have been better to keep them without any action such that automation doesn't break.
(Reporter)

Comment 4

5 years ago
JSBugMon: This bug has been automatically confirmed to be still valid (reproduced on revision 9e64f779b611).
(Reporter)

Updated

5 years ago
Whiteboard: [jsbugmon:update,reconfirm] → [jsbugmon:update,reconfirm,ignore]
(Assignee)

Updated

5 years ago
Assignee: general → kvijayan
(Assignee)

Comment 5

5 years ago
Created attachment 619657 [details] [diff] [review]
Fix

The issue here is simple: IonBuilder's handling of jsop_pos tries to optimize the case when the input is an int32 by leaving the input as-is.

However, when checking for this case, it checks the 'rval' (result value) typeset for the jsop_pos operation instead of the 'ival' (input value) typeset.  The rval typeset for jsop_pos is optimistically initialized to INT32.  This devolves into a ToInt32 of a string in MIR, which triggers an assert because the LIRGenerator doesn't yet handle compiled String->Int32 conversions.
Attachment #619657 - Flags: review?(dvander)
Attachment #619657 - Flags: review?(dvander) → review+
(Assignee)

Comment 6

5 years ago
Created attachment 619659 [details] [diff] [review]
FIX: Better diff with more context

The previous diff was barebones.  This is the same patch, but with more patch context and function names present.
Attachment #619657 - Attachment is obsolete: true
Attachment #619659 - Flags: review?(dvander)
Attachment #619659 - Flags: review?(dvander) → review+
(Assignee)

Comment 7

5 years ago
http://hg.mozilla.org/projects/ionmonkey/rev/ff4083f660ed
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

5 years ago
Automatically extracted testcase for this bug was committed:

https://hg.mozilla.org/mozilla-central/rev/2e891e0db397
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.