Last Comment Bug 746452 - textPath does not handle startOffset with non-user-unit/non-percentage units correctly
: textPath does not handle startOffset with non-user-unit/non-percentage units ...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: SVG (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla15
Assigned To: Robert Longson
:
: Jet Villegas (:jet)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-17 20:33 PDT by Cameron McCormack (:heycam)
Modified: 2012-05-25 08:25 PDT (History)
2 users (show)
longsonr: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
test (287 bytes, image/svg+xml)
2012-04-17 20:33 PDT, Cameron McCormack (:heycam)
no flags Details
patch (2.82 KB, patch)
2012-05-24 03:32 PDT, Robert Longson
jwatt: review+
Details | Diff | Splinter Review

Description Cameron McCormack (:heycam) 2012-04-17 20:33:53 PDT
Created attachment 616005 [details]
test

It looks like when startOffset is not a percetange, we just take the numeric part of the length and interpret it as user units, regardless of the unit.

In the attachment I would expect both "abc"s to be at the same x position.  Opera gets this right, WebKit doesn't.
Comment 1 Robert Longson 2012-05-24 03:32:00 PDT
Created attachment 626748 [details] [diff] [review]
patch
Comment 3 :Ms2ger (⌚ UTC+1/+2) 2012-05-25 08:25:56 PDT
https://hg.mozilla.org/mozilla-central/rev/4b3a21cee66e

Note You need to log in before you can comment on or make changes to this bug.