Last Comment Bug 746456 - Disable cubeb nsAudioStream backend on Aurora
: Disable cubeb nsAudioStream backend on Aurora
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Audio/Video (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla14
Assigned To: Matthew Gregan [:kinetik]
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-17 20:52 PDT by Matthew Gregan [:kinetik]
Modified: 2012-05-02 15:27 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
fixed


Attachments
patch to be landed on Aurora after next uplift (796 bytes, patch)
2012-04-17 20:53 PDT, Matthew Gregan [:kinetik]
roc: review+
lukasblakk+bugs: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Matthew Gregan [:kinetik] 2012-04-17 20:52:15 PDT
Bug 623444 and friends are in the process of landing.  Right now we've got the cubeb nsAudioStream backend enabled by default and backends present for OS X and Win32.  They've only been on mozilla-central for a couple of days, so they're nowhere near adequately tested for wider exposure on Aurora yet.

This bug tracks a patch to disable the cubeb nsAudioStream backend by default on Aurora.  It's a simple pref flip, and returns us to the old backend that has been in use up until a few days ago, so it's extremely low risk.
Comment 1 Matthew Gregan [:kinetik] 2012-04-17 20:53:35 PDT
Created attachment 616007 [details] [diff] [review]
patch to be landed on Aurora after next uplift
Comment 2 Matthew Gregan [:kinetik] 2012-04-17 23:45:33 PDT
Comment on attachment 616007 [details] [diff] [review]
patch to be landed on Aurora after next uplift

Note that this patch is to be landed on Aurora after the next uplift on the 24th April.

[Approval Request Comment]
Regression caused by (bug #): Not a regression.
User impact if declined: New bugs in media playback.
Testing completed (on m-c, etc.): Yes.
Risk to taking this patch (and alternatives if risky): Exposing new code too early.
String changes made by this patch: None.

Requesting approval in advance of the Aurora uplift on the 24th so that this is ready to land immediately afterwards.
Comment 3 Alex Keybl [:akeybl] 2012-04-18 15:28:45 PDT
Tracking for FF14, we'll add this to the merge documentation and request that you land at that time.
Comment 4 Lukas Blakk [:lsblakk] use ?needinfo 2012-04-24 10:51:02 PDT
Comment on attachment 616007 [details] [diff] [review]
patch to be landed on Aurora after next uplift

merge to aurora has now occurred, please go ahead and land this to mozilla-aurora.
Comment 5 Matthew Gregan [:kinetik] 2012-04-24 14:20:56 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/2bc277479ad2

Note You need to log in before you can comment on or make changes to this bug.