imglib needs to check pres context GetImageAnimationMode

VERIFIED DUPLICATE of bug 74169

Status

()

Core
ImageLib
VERIFIED DUPLICATE of bug 74169
17 years ago
17 years ago

People

(Reporter: Akkana Peck, Assigned: Stuart Parmenter)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Bug 17686 regressed with the libpr0n landing, because libpr0n doesn't check the
pres shell's GetImageAnimationMode().  

Here's how it was called in the old imglib:
http://lxr.mozilla.org/seamonkey/source/modules/libimg/src/if.cpp#1833

which was called from IL_GetImage on line 1918 of the same file.

I can add the call to libpr0n if you point me in the right direction (perhaps in
imgContainer::Init or imgContainer::StartAnimation?)
(Reporter)

Updated

17 years ago
Blocks: 17686
(Reporter)

Comment 1

17 years ago
Added a small test case in the url field.

Comment 2

17 years ago
This seems to be the same as bug 74169. Please ... ;-)
(Reporter)

Comment 3

17 years ago

*** This bug has been marked as a duplicate of 74169 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 4

17 years ago
Verified duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.