Blank page appears when reloading a page in landscape mode

RESOLVED WORKSFORME

Status

()

Firefox for Android
General
RESOLVED WORKSFORME
6 years ago
2 years ago

People

(Reporter: Paul Feher, Assigned: mfinkle)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(blocking-fennec1.0 +)

Details

(Reporter)

Description

6 years ago
Nightly Fennec 14.0a1 (2012-04-18)
Device: HTC Desire Z
OS: Android 2.3.3

Steps to reproduce:
1. Load msnbc.com in portrait mode
2. Rotate the device in landscape mode
3. Reload the page

Expected:
The page content is properly loaded.

Actual:
A blank page is displayed. Only by scrolling the page down the content is displayed.

NOTE:Please see the attached video.
http://youtu.be/ika0ffzp2Pc
Please try the build I posted here [1], if you can't reproduce, please dupe this bug to 732016.

[1] http://people.mozilla.com/~atrain/mobile/builds/fennec-14.0a1.en-US.android-arm.apk
(Reporter)

Comment 2

6 years ago
This is still reproducible. The chances to reproduce it is higher if you scroll down the page before you change the device orientation.
Nominating for blocking-fennec1.0.  Is this a recent regression?  If so, a regression range would be useful.
blocking-fennec1.0: --- → ?
Could not reproduce on the captivate with today's build 4/18/2012.
Does not occur on HTC Desire HD 4/18/2012 either...

Paul... what's the video suppose to show us about fennec?  :)
(Reporter)

Comment 5

6 years ago
Excuse me, wrong video :) this is the good link:
http://youtu.be/ShDuiNH26GU

Comment 6

6 years ago
Kevin, can you reproduce on this particular device?
Keywords: qawanted
I can reproduce using the following steps using a Galaxy S II or G2 (Desire Z).

1. Load msnbc.com in portrait mode
1a. pan down the page
2. Rotate the device in landscape mode
3. Reload the page

Using the exact steps from comment 0 do not work.
Keywords: qawanted
Also see this on the SII. Cant reproduce on the Galaxy Nexus.

Updated

6 years ago
Assignee: nobody → mark.finkle
blocking-fennec1.0: ? → +

Comment 9

6 years ago
This was resolved earlier this week, correct (by backouts)
Keywords: qawanted
(Reporter)

Comment 10

6 years ago
This is still reproducible using steps from comment 7 on:

Nightly Fennec 15.0a1 (2012-04-25)
Device: HTC Desire Z
OS: Android 2.3.3
Keywords: qawanted
Re-tested on SII, Nightly (04/30) WFM
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 12

6 years ago
This is still reproducible on:
Nightly Fennec 15.0a1 (2012-05-01)
Device: HTC Desire Z (Android 2.3.3) and Motorola Droid Pro (Android 2.3.4)
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Kevin, can you repro?

Comment 14

6 years ago
Adding qawanted for comment #13
Keywords: qawanted
(Reporter)

Comment 15

6 years ago
This issue is not reproducible anymore on:
Nightly 15.0a1 (2012-05-21)
Device: HTC Desire Z
OS: Android 2.3.3
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.