After opening the hardware keyboard and dismissing the AwsomeBar the viewport is not repainted in landscape mode

RESOLVED WORKSFORME

Status

()

Firefox for Android
General
RESOLVED WORKSFORME
6 years ago
2 years ago

People

(Reporter: AdrianT, Assigned: cpeterson)

Tracking

14 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(blocking-fennec1.0 +)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 616093 [details]
logs

Fennec/14.0a1 2012-04-18
Device: Motorola Droid 2 (Android 2.3)/ HTC Desire Z (Android 2.3)

Steps to reproduce:
1. In Portrait mode visit any website.
2. Tap in the AwsomeBar.
3. Open the Hardware keyboard.
4. Press the back button to dismiss the AwsomeBar.
5. Reload the page or tap in the URL and navigate to a different page.

Expected results:
Everything loads without any issues.

Actual results:
If the page is reloaded the viewport is fixed and the user can't scroll.
If the user navigates to a second website the page loads under the current viewport leaving the content displayed. This behavior is reproducible until the user restarts Firefox. rotating the device once repaints the content.

Notes:
Please see the videocapture: http://youtu.be/LFtOq8cjEec
I could reproduce this on the 23rd build. I cannot reproduce this on the 25th build.
Status: NEW → RESOLVED
blocking-fennec1.0: --- → ?
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME

Comment 2

6 years ago
This is still reproducible on:
Nightly Fennec/15.0a1 2012-05-03
Device:HTC Desire Z 
OS: Android 2.3.3
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 3

6 years ago
The issue persists, if the user navigates to a second website the page loads under the current viewport leaving the content displayed. But now the viewport is not fixed, you can scroll the page up/down. Also is not reproducible if the page is reloaded.
Can we reproduce this using landscape, but no hardware keyboard? Also, can you retest this with a new nightly? (we landed a patch to fix "handheldfriendly" conflicts)
Keywords: qawanted

Comment 5

6 years ago
I can reproduce this using latest Nightly Fennec/15.0a1 (2012-05-06) on HTC Desire Z(2.3.3.) whit the initial STR, although the behavior is a little bit different. The second page is not loaded at all only a blank page is displayed, if the device is rotated from landscape to portrait only the view-port is updated leaving the rest of the page blank. After reloading the page a blank page appears. Please see the log file.

The issue is not reproducible when using landscape mode without opening the hardware keyboard.
Keywords: qawanted

Comment 6

6 years ago
Created attachment 621543 [details]
Logs for this issue
Assignee: nobody → cpeterson
blocking-fennec1.0: ? → +
(Assignee)

Comment 7

6 years ago
I was able to intermittently reproduce this bug on Droid 2. Sometimes the page will reload and scroll, but will not paint the page as you scroll down. Sometimes the page will repeat parts of the page.

This seems like a graphics invalidation problem where the browser has some old state from portrait mode that did not get updated when the HKB caused the AwesomeScreen to rotate. Rotating the device without opening the HKB does not seem to cause the problem.
Does this still happen Paul?

Comment 9

6 years ago
I can't reproduce it on today's Nightly (2012-05-22) using HTC Desire Z (2.3.3)
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.