Last Comment Bug 746548 - crash in nsCacheService::Lock
: crash in nsCacheService::Lock
Status: RESOLVED FIXED
[native-crash][mobile-crash]
: crash, regression, topcrash
Product: Core
Classification: Components
Component: Networking: Cache (show other bugs)
: 14 Branch
: ARM Android
: -- critical (vote)
: mozilla14
Assigned To: Brian Nicholson (:bnicholson)
:
Mentors:
Depends on:
Blocks: 745075
  Show dependency treegraph
 
Reported: 2012-04-18 06:42 PDT by Catalin Suciu [:csuciu]
Modified: 2012-04-19 07:21 PDT (History)
11 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
beta+


Attachments
patch (2.12 KB, patch)
2012-04-18 12:49 PDT, Brian Nicholson (:bnicholson)
mark.finkle: review+
Details | Diff | Review

Description Catalin Suciu [:csuciu] 2012-04-18 06:42:17 PDT
This bug was filed from the Socorro interface and is 
report bp-b43ea2d1-2179-42b5-bd4e-bf9742120418 .
=============================================================
Comment 1 Mark Finkle (:mfinkle) (use needinfo?) 2012-04-18 06:58:56 PDT
Did bug 745075 land in m-c in time to potential be related to this?
Comment 2 Scoobidiver (away) 2012-04-18 08:16:05 PDT
It first appeared in 14.0a1/20120418030652. The regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c61e7c3a232a&tochange=0c7e2911be75
bug 745075 is in the regression range.
Comment 3 Martijn Wargers [:mwargers] (not working for Mozilla) 2012-04-18 12:20:43 PDT
Bug 746697 related?
Comment 4 Scoobidiver (away) 2012-04-18 12:41:20 PDT
(In reply to Martijn Wargers [:mw22] (QA - IRC nick: mw22) from comment #3)
> Bug 746697 related?
I don't think so because bug 746697 happens also in 11.0 on Mac OS X.
Comment 5 Brian Nicholson (:bnicholson) 2012-04-18 12:49:19 PDT
Created attachment 616253 [details] [diff] [review]
patch

It looks like the cache service is lazily loaded, so gService (the global cache instance) isn't set until a page is loaded.

STR in Nightly:
1) Open Fennec, stay at about:home
2) Push home
Comment 6 Mark Finkle (:mfinkle) (use needinfo?) 2012-04-18 13:02:09 PDT
marking beta+ to fix the crash. low risk fix.
Comment 7 Brian Nicholson (:bnicholson) 2012-04-18 13:09:12 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/f6edc3d72a22
Comment 8 Bill Gianopoulos [:WG9s] 2012-04-18 14:01:19 PDT
Just asking, because I see this same issue in Android XUL builds.  Would this issue effect both and will this fix it for both?
Comment 9 :Ehsan Akhgari (busy, don't ask for review please) 2012-04-19 07:21:45 PDT
https://hg.mozilla.org/mozilla-central/rev/f6edc3d72a22

Note You need to log in before you can comment on or make changes to this bug.