Flash flickers at the end of a pan or zoom on gingerbread and froyo

VERIFIED FIXED in Firefox 14

Status

()

Firefox for Android
General
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: tchung, Assigned: snorp)

Tracking

Trunk
Firefox 15
ARM
Android
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox14 verified, blocking-fennec1.0 +, fennec14+)

Details

(URL)

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

6 years ago
Visit a site thats build on full flash, and watch yourself panning and tapping the screen will flicker.   Visit the URL in the bug for an example.  

Here's a video: http://www.youtube.com/watch?v=jrxePPRFyAg

Repro:
1) 04-17-2012 nightly, HTC Sensation, Android 2.3.4
2) visit a full flash site.  (see URL.  also gotmilk.com is one)
3) when site finishes loading, try to pan the screen.   
4) Verify page flickers.

Expected:
- No flash site flickering

Actual:
- flickering
(Reporter)

Updated

6 years ago
tracking-fennec: --- → ?
Related to bug 727116?
Bug 719865 was marked as a duplicate of that bug.
(Reporter)

Comment 2

6 years ago
(In reply to Martijn Wargers [:mw22] (QA - IRC nick: mw22) from comment #1)
> Related to bug 727116?
> Bug 719865 was marked as a duplicate of that bug.

Yeah possibly.  i can't reproduce the flash flickering on my Galaxy Nexus, Android 4.0.2.
blocking-fennec1.0: --- → ?
snorp will be landing a major change to how we paint flash, so please retest once that lands.

Snorp, can you put the bug number for that in a comment here?
Keywords: qawanted
Created attachment 618590 [details]
logs
Comment on attachment 618590 [details]
logs

Sorry I added the file to the wrong bug.
Attachment #618590 - Attachment is obsolete: true
Bug 727116 describes a change where we will take a snapshot while we pan/zoom, but that's still probably going to be bad for this case. Maybe what we need to do is detect these full page flash applets and not do any of that stuff.
(Reporter)

Comment 7

6 years ago
(In reply to Brad Lassey [:blassey] from comment #3)
> snorp will be landing a major change to how we paint flash, so please retest
> once that lands.
> 
> Snorp, can you put the bug number for that in a comment here?

removing qawanted for now.  comment 6 hints that the fix for bug 727116 may not fix this bug.

fwiw, 04-26-2012 nightly, incredible S.  Still reproducing flash flickering today.
Keywords: qawanted
(Reporter)

Comment 8

6 years ago
A different full flash site is now causing panning to get a the crash from bug 738198.  Should this be duped?

See https://bugzilla.mozilla.org/show_bug.cgi?id=738198#c10 for more details.
Depends on: 738198
(Reporter)

Comment 9

6 years ago
Not just full flash anymore.  try a site with flash ads (eg. www.marketwatch.com).   tap on the flash ad, and it continues to flicker.

HTC Sensation, latest-aurora build 4/30/2012, Android 2.3.4
Summary: Full Flash sites will flicker on touch and panning → Sites with Flash ads (or full flash sites) will flicker on touch and panning
blocking-fennec1.0: ? → +
Snorp, thoughts on this?
Assignee: nobody → snorp
blocking-fennec1.0: + → ?
Summary: Sites with Flash ads (or full flash sites) will flicker on touch and panning → Flash flickers at the end of a pan or zoom on gingerbread and froyo
tracking-fennec: ? → 14+
blocking-fennec1.0: ? → +
Created attachment 621162 [details] [diff] [review]
Don't use placeholder for full page plugins on Android
Attachment #621162 - Flags: review?(blassey.bugs)
Attachment #621162 - Attachment is obsolete: true
Attachment #621162 - Flags: review?(blassey.bugs)
Created attachment 621178 [details] [diff] [review]
Don't use placeholder for full page plugins on Android
Attachment #621178 - Flags: review?(blassey.bugs)
The above patch disables the placeholder hack if the plugin is more than 10% of the screen dimension. This seems to make things much happier for me.
Attachment #621178 - Flags: review?(blassey.bugs) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/9f6e78dfd4a4
http://hg.mozilla.org/mozilla-central/rev/9f6e78dfd4a4
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → Firefox 15
Blocks: 727116
Comment on attachment 621178 [details] [diff] [review]
Don't use placeholder for full page plugins on Android

[Triage Comment]
Attachment #621178 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/982ca139a92a
status-firefox14: --- → fixed
Unable to reproduce on Nightly 15.0a1 (2012-05-22)
                       Aurora 14.0a2 (2012-05-22)
Samsung Galaxy SII (2.3.4)

The full flash sites are not flickering when panning or tapping the screen. (I used http://verdeteacafe.net/ and http://gotmilk.com ). Also the flash ads on other pages (cnn.com, etc..) are working fine.
Status: RESOLVED → VERIFIED
status-firefox14: fixed → verified
You need to log in before you can comment on or make changes to this bug.