Last Comment Bug 746648 - Too large script labels in various pages
: Too large script labels in various pages
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Debugger (show other bugs)
: Trunk
: All All
: P2 normal (vote)
: Firefox 15
Assigned To: Victor Porof [:vporof][:vp]
:
Mentors:
: 759629 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-18 10:38 PDT by Panos Astithas [:past]
Modified: 2012-05-31 01:58 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v1 (4.63 KB, patch)
2012-05-30 03:40 PDT, Victor Porof [:vporof][:vp]
no flags Details | Diff | Splinter Review
v1.1 (4.78 KB, patch)
2012-05-30 03:46 PDT, Victor Porof [:vporof][:vp]
past: review+
Details | Diff | Splinter Review

Description Panos Astithas [:past] 2012-04-18 10:38:09 PDT
STR:
1) Visit cnn.com
2) Open the script debugger
3) Observe the huge labels in the script list

In SS__getScriptLabel we trim the query string before deciding on a unique, short label for the script. In this case, however, the query string is what differentiates the script URLs.

The best mitigation I came up with is using the path info as usual, but instead of appending the whole query string, just add a unique subset of it, probably with ellipsis characters before and after.
Comment 1 Panos Astithas [:past] 2012-05-30 00:24:21 PDT
*** Bug 759629 has been marked as a duplicate of this bug. ***
Comment 2 Panos Astithas [:past] 2012-05-30 00:30:59 PDT
http://rawkes.com/ from bug 759629 is another good case for huge script labels due to long query strings. In this particular case however, the query string delimiter character '?' is missing, which confuses SS__trimUrlQuery. I'm not even sure such URLs are valid:

http://rawkes.com.woopra-ns.com/visit/ra=RTQE96Y6BFVTG8BQ9MQZE9CPAIC85Z39&cookie=R93U390OEXA93DSSGVQ166PUYBM8G9Q9&vid=-1&meta=MzYxNzI3JjMmNCYyMTMmMTMzODM2MjM1MjQ3MyYxMzM4MzYyOTk0MTc3JiYxMDAmJjImJiYm&alias=rawkes.com&language=en-US&page=%2F&pagetitle=Exploring%20the%20Frontiers%20of%20Online%20Media%20%7C%20Rawkes&referer=&screen=1920x1200&localtime=10%3A29
Comment 3 Victor Porof [:vporof][:vp] 2012-05-30 02:15:15 PDT
(In reply to Panos Astithas [:past] from comment #2)
> I'm not even sure such URLs are valid

Sometimes I'm surprised the whole internet thing even works...
Comment 4 Victor Porof [:vporof][:vp] 2012-05-30 03:40:02 PDT
Created attachment 628299 [details] [diff] [review]
v1

Works.
Comment 5 Victor Porof [:vporof][:vp] 2012-05-30 03:46:59 PDT
Created attachment 628301 [details] [diff] [review]
v1.1

I just realized that until now, the whole "for (let i = 0; i < vs._scripts.itemCount; i++)" check for script urls was incorrect, because there was no 1:1 relationship between the test urls array and the actual added urls in the dropdown. This means that, although it worked and the order wasn't important, not all the urls were tested. Fixed in this version.
Comment 6 Panos Astithas [:past] 2012-05-30 12:23:45 PDT
Comment on attachment 628301 [details] [diff] [review]
v1.1

Review of attachment 628301 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM.
Comment 8 Tim Taubert [:ttaubert] (on PTO, back Aug 29th) 2012-05-31 01:58:27 PDT
https://hg.mozilla.org/mozilla-central/rev/fd76266dc5ca

Note You need to log in before you can comment on or make changes to this bug.