Last Comment Bug 746650 - Unable to create language pack on Windows XP: Error message: "couldn't compile a simple C file"
: Unable to create language pack on Windows XP: Error message: "couldn't compil...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: unspecified
: x86 Windows XP
: -- normal (vote)
: mozilla15
Assigned To: Mike Hommey [:glandium]
:
Mentors:
Depends on:
Blocks: 603370
  Show dependency treegraph
 
Reported: 2012-04-18 10:38 PDT by Sebastian H. [:aryx][:archaeopteryx]
Modified: 2012-04-25 07:46 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Don't run expandlibs configure tests when building with --disable-compile-environment (901 bytes, patch)
2012-04-18 12:45 PDT, Mike Hommey [:glandium]
ted: review+
Details | Diff | Splinter Review
config.log for cl: Command not found (6.28 KB, text/plain)
2012-04-19 01:34 PDT, Sebastian H. [:aryx][:archaeopteryx]
no flags Details

Description Sebastian H. [:aryx][:archaeopteryx] 2012-04-18 10:38:22 PDT
Windows XP SP 3 32-bit, MozillaBuild 1.6

I tried to create a German language pack for Aurora (13 Branch) and followed the manual at https://developer.mozilla.org/En/Creating_a_patch and https://developer.mozilla.org/en/Localization_Quick_Start_Guide

make -f client.mk aborts like this:

checking for wget... checking for wget... wget
wget
checking for pkg-config... no
*** The pkg-config script could not be found. Make sure it is
*** in your path, or set the PKG_CONFIG environment variable
*** to the full path to pkg-config.
*** Or see http://www.freedesktop.org/software/pkgconfig to get pkg-config.
configure: warning: When not building jemalloc, you need to set WIN32_REDIST_DIR
 to the path to the Visual C++ Redist (usually VCINSTALLDIR\redist\x86\Microsoft
.VC80.CRT, for VC++ v8) if you intend to distribute your build.
checking what kind of list files are supported by the linker... configure: error
: couldn't compile a simple C file
*** Fix above errors and then restart with               "make -f client.mk buil
d"
make[2]: *** [configure] Error 1
make[2]: Leaving directory `/f/Mozilla/Coding/Firefox/Code/mozilla-aurora-unchan
ged'
make[1]: *** [/f/Mozilla/Coding/Firefox/Code/mozilla-aurora-unchanged/../firefox
-build/Makefile] Error 2
make[1]: Leaving directory `/f/Mozilla/Coding/Firefox/Code/mozilla-aurora-unchan
ged'
make: *** [build] Error 2


The .mozconfig:

mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/../firefox-build
ac_add_options --disable-angle
ac_add_options --disable-compile-environment
ac_add_options --with-l10n-base=../l10n-central
ac_add_options --enable-application=browser


Analysis by Ted Mielczarek:

ted: sounds like we added a new check that errors on --disable-compile-environment builds
ted: make it block bug  603370 
ted: which looks like where we broke this
ted: http://mxr.mozilla.org/mozilla-central/source/build/autoconf/expandlibs.m4#5
ted: http://mxr.mozilla.org/mozilla-central/source/build/autoconf/expandlibs.m4#26 specifically is that error you're getting
Comment 1 Mike Hommey [:glandium] 2012-04-18 10:43:13 PDT
It's likely to not be related to bug 603370. Please attach your config.log to get the actual error.
Comment 2 Mike Hommey [:glandium] 2012-04-18 10:47:44 PDT
Err, ted is right, it's likely a missing
if test "$COMPILE_ENVIRONMENT"; then
from bug 603370
Comment 3 Mike Hommey [:glandium] 2012-04-18 12:45:03 PDT
Created attachment 616250 [details] [diff] [review]
Don't run expandlibs configure tests when building with --disable-compile-environment
Comment 4 Sebastian H. [:aryx][:archaeopteryx] 2012-04-19 01:34:56 PDT
Created attachment 616494 [details]
config.log for cl: Command not found

Modifying the configure.in like glandium proposed allows to run make -f client.mk longer, but it still aborts with

make[6]: cl: Command not found
Comment 5 Mike Hommey [:glandium] 2012-04-25 00:14:25 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/864ae3bff0b2

Archaeopteryx, please file a separate bug for comment #4, it is a separate issue.

Note You need to log in before you can comment on or make changes to this bug.