Last Comment Bug 746728 - Add type lookup fallback for emulator
: Add type lookup fallback for emulator
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Hardware Abstraction Layer (HAL) (show other bugs)
: unspecified
: All Gonk (Firefox OS)
: -- normal (vote)
: mozilla14
Assigned To: Michael Wu [:mwu]
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-18 14:00 PDT by Michael Wu [:mwu]
Modified: 2012-04-19 07:22 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Add a sensor index fallback (876 bytes, patch)
2012-04-18 14:00 PDT, Michael Wu [:mwu]
gal: review+
Details | Diff | Splinter Review

Description Michael Wu [:mwu] 2012-04-18 14:00:33 PDT
Created attachment 616281 [details] [diff] [review]
Add a sensor index fallback

hardware/sensors.h provides us with a type field in sensors_event_t and we use it. This doesn't work on the emulator because that implementation never fills it in. The Android sensor service never checks that field so the qemu impl gets away with leaving it zero.

Note You need to log in before you can comment on or make changes to this bug.