Last Comment Bug 746990 - crash in nsXULTreeAccessible::Value
: crash in nsXULTreeAccessible::Value
Status: VERIFIED FIXED
[good first bug][mentor=trev.saunders...
: crash
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: Other Branch
: x86 Windows NT
: -- critical (vote)
: mozilla15
Assigned To: Mark Capella [:capella]
:
:
Mentors:
https://getsatisfaction.com/mozilla_m...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-19 07:51 PDT by Marco Zehe (:MarcoZ)
Modified: 2012-07-24 04:11 PDT (History)
7 users (show)
ryanvm: in‑testsuite?
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (v1) (809 bytes, patch)
2012-04-26 17:48 PDT, Mark Capella [:capella]
surkov.alexander: review+
Details | Diff | Splinter Review

Description Marco Zehe (:MarcoZ) 2012-04-19 07:51:01 PDT
This bug was filed from the Socorro interface and is 
report bp-c7d007a9-42bd-48eb-96a7-0695d2120419 .
============================================================= 
I did the following:
1. Opened Thunderbird.
2. Opened the IM module and logged on to a few IRC channels.
3. Right-clicked one of the IRC channels and selected "Close this conversation".

Note that I had right-clicked the "Nickserv" message conversation before and closed it without incident, so this may not be reproducible at will.
Comment 1 David Bolter [:davidb] 2012-04-19 08:01:18 PDT
It looks like the accessible is alive (probably in doc cache) but has been shutdown, leaving mTreeView nulled out. Meanwhile NVDA is asking for a value and kaboom.
Comment 2 alexander :surkov 2012-04-19 08:03:40 PDT
(In reply to David Bolter [:davidb] from comment #1)
> It looks like the accessible is alive (probably in doc cache) but has been
> shutdown,

nope

> leaving mTreeView nulled out.

yes
Comment 3 David Bolter [:davidb] 2012-04-19 08:06:38 PDT
How is mTreeView nulled out?
Comment 4 Trevor Saunders (:tbsaunde) 2012-04-19 08:28:40 PDT
(In reply to David Bolter [:davidb] from comment #3)
> How is mTreeView nulled out?

TreViewChanged(), I think the right fix here is just adding a null check.
Comment 5 David Bolter [:davidb] 2012-04-19 11:49:47 PDT
If the tree view changes, shouldn't we destroy the accessible and create a new one?
Comment 6 David Bolter [:davidb] 2012-04-19 11:50:12 PDT
When do tree views change?
Comment 7 alexander :surkov 2012-04-22 20:56:10 PDT
(In reply to David Bolter [:davidb] from comment #5)
> If the tree view changes, shouldn't we destroy the accessible and create a
> new one?

tree accessible? nope, 'cause treeview is responsible for data, i.e rows

(In reply to David Bolter [:davidb] from comment #6)
> When do tree views change?

when the author changes the tree view.
Comment 8 alexander :surkov 2012-04-23 00:51:33 PDT
per comment #4, add a mTreeView null check into Value() method
Comment 9 David Bolter [:davidb] 2012-04-23 06:36:28 PDT
(In reply to alexander :surkov from comment #7)
> (In reply to David Bolter [:davidb] from comment #6)
> > When do tree views change?
> 
> when the author changes the tree view.

Heh, I was wondering more about when and how often. I suspect this happens more in tbird.

OK I think I know where this bugs going :)
Comment 10 alexander :surkov 2012-04-24 00:36:13 PDT
(In reply to David Bolter [:davidb] from comment #9)
> Heh, I was wondering more about when and how often. I suspect this happens
> more in tbird.

sort of strange question because that depends on the author (application) completely. Basically when the tree gets into no-data state then I think the author nulls out the treeview. 

I would suspect that too because tbird UI uses XUL trees a lot.

> OK I think I know where this bugs going :)

where? :)
Comment 11 Mark Capella [:capella] 2012-04-26 17:48:52 PDT
Created attachment 618877 [details] [diff] [review]
Patch (v1)

Quick fix for a "red" bug ... built and tested locally ...
Comment 12 alexander :surkov 2012-04-26 23:03:28 PDT
Comment on attachment 618877 [details] [diff] [review]
Patch (v1)

thanks for doing this
Comment 14 Ryan VanderMeulen [:RyanVM] 2012-04-29 13:51:36 PDT
http://hg.mozilla.org/mozilla-central/rev/bba6161714f2
Comment 15 Wayne Mery (:wsmwk, NI for questions) 2012-07-24 04:11:14 PDT
reporter in https://getsatisfaction.com/mozilla_messaging/tags/bug_746990 indicates crash is fixed for thunderbird 15

Note You need to log in before you can comment on or make changes to this bug.