Install software notification doorhanger popup can appear from page in background tab

VERIFIED FIXED in Firefox 14

Status

()

defect
VERIFIED FIXED
7 years ago
3 years ago

People

(Reporter: martijn.martijn, Assigned: Margaret)

Tracking

({testcase})

Trunk
Firefox 15
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox14 verified, firefox15 verified, blocking-fennec1.0 +)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Steps to reproduce:
- Long tap on this link and open in new tab: http://people.mozilla.org/~mwargers/tests/dom/multiple_doorhangers.htm

Expected result:
- No notification doorhanger appears

Actual result:
- Install software notification doorhanger appears

Tested on the Samsung Galaxy Nexus, Android4.0.
blocking-fennec1.0: --- → ?
Reproduced (04/30)
Assignee: nobody → margaret.leibovic
blocking-fennec1.0: ? → +
Posted patch patch (obsolete) — Splinter Review
Problem here is that we aren't passing a tab id to doorhanger.show(), so it's just picking the current one. This patch just ports over logic from desktop:
http://mxr.mozilla.org/mozilla-central/source/browser/base/content/browser.js#715

(Desktop uses a browser to keep track of doorhangers, we use a tab)
Attachment #619732 - Flags: review?(mark.finkle)
Comment on attachment 619732 [details] [diff] [review]
patch

I assume that we couldn't do something like:

+        let win = installInfo.originatingWindow;
+        let tab = BrowserApp.getTabForWindow(win.top);

If not, I am fine with the docShell based code
Attachment #619732 - Flags: review?(mark.finkle) → review+
Posted patch simpler patchSplinter Review
(In reply to Mark Finkle (:mfinkle) from comment #3)

> I assume that we couldn't do something like:
> 
> +        let win = installInfo.originatingWindow;
> +        let tab = BrowserApp.getTabForWindow(win.top);

Yeah, this works. I looked into why desktop does this docShell business, and that was added way long ago (2004) before there was an installInfo interface.
Attachment #619732 - Attachment is obsolete: true
https://hg.mozilla.org/mozilla-central/rev/281574985410
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 15
Comment on attachment 619961 [details] [diff] [review]
simpler patch

[Approval Request Comment]
Regression caused by (bug #): n/a
User impact if declined: add-on install doorhanger can appear in wrong tab
Testing completed (on m-c, etc.): just landed on m-c
Risk to taking this patch (and alternatives if risky): low risk, only affects add-on install doorhaner
String changes made by this patch: n/a
Attachment #619961 - Flags: approval-mozilla-aurora?
Attachment #619961 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified/Fixed on:
Nightly Fennec 15.0a1 (2012-05-30)
Aurora Fennec 14.0a2 (2012-05-30)
Devices: HTC Desire Z (Android 2.3.3)

Verified using the STR from comment 0.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.