Last Comment Bug 747048 - Fix libjingle linkage on mac
: Fix libjingle linkage on mac
Status: RESOLVED FIXED
[qa-]
:
Product: Core
Classification: Components
Component: WebRTC (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Eric Rescorla (:ekr)
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-19 09:37 PDT by Eric Rescorla (:ekr)
Modified: 2012-07-27 10:28 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Fix libjingle linkage (2.12 KB, patch)
2012-04-19 09:37 PDT, Eric Rescorla (:ekr)
rjesup: review+
Details | Diff | Splinter Review

Description Eric Rescorla (:ekr) 2012-04-19 09:37:33 PDT
Fix for libjingle link errors
Comment 1 Eric Rescorla (:ekr) 2012-04-19 09:37:37 PDT
Created attachment 616627 [details] [diff] [review]
Fix libjingle linkage
Comment 2 Randell Jesup [:jesup] 2012-04-19 14:16:03 PDT
What was referencing unixfilesystem?  And why did it/does it work on alder/default?

I'm loathe to make changes without knowing why...
Comment 3 Eric Rescorla (:ekr) 2012-04-19 16:26:11 PDT
Here is the link error:

ld: warning: could not create compact unwind for _ffi_call_unix64: does not use RBP or RSP based frame
Undefined symbols for architecture x86_64:
  "vtable for talk_base::UnixFilesystem", referenced from:
      talk_base::UnixFilesystem::UnixFilesystem()in fileutils.o
  NOTE: a missing vtable usually means the first non-inline virtual member function has no definition.
  "cricket::DeviceManagerFactory::Create()", referenced from:
      cricket::ChannelManager::ChannelManager(talk_base::Thread*)in channelmanager.o
      cricket::ChannelManager::ChannelManager(talk_base::Thread*)in channelmanager.o

What makes you think it works on alder/default? This is alder/default I'm having the problem on.
Note that the included files differ between Mac and Linux here.
Comment 4 Randell Jesup [:jesup] 2012-04-19 17:58:29 PDT
Because the builders have no trouble building alder/default.  That doesn't mean that it isn't wrong and should be fixed, but I just want to understand *why* it's different - XCode version?  OS version?  Extra stuff installed?  Different build options?

I'll note that probably the os_posix -> os_linux change I made in libjingle (line 412) is probably the cause of the problem.  I changed it because it was breaking win32, and I can't test mac easily.
Comment 5 Eric Rescorla (:ekr) 2012-04-20 07:49:12 PDT
Fixed in: http://hg.mozilla.org/projects/alder/rev/64431beeafbe

Note You need to log in before you can comment on or make changes to this bug.