align="center" not working on COL and COLGROUP

VERIFIED DUPLICATE of bug 915

Status

()

Core
Layout: Tables
P3
normal
VERIFIED DUPLICATE of bug 915
19 years ago
18 years ago

People

(Reporter: ham.nguyen, Assigned: karnaze (gone))

Tracking

({testcase})

Trunk
x86
Linux
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT-])

Attachments

(2 attachments)

(Reporter)

Description

19 years ago
Am reporting 3 problems against Mozilla M6, both related to HTML table:

1. When a table cell is empty (i.e. containing just "<td></td>"), and table border is non-0,
Mozilla does NOT display a border around that cell, so it looks "raised flat" compared to
other cells.  Workaround: use <td>&nbsp;</td> instead.

2. HTML 4.0 has a new tag: <COL> so I can set common attributes (i.e. align="center")
for an entire column of cells.  Mozilla seems to ignore this new tag.

3. Mozilla also seems to ignore another new HTML 4.0 <COLGROUP> too, but I can't be sure.


Fyi, all 3 problems also exist in Netscape 4.6.
For comparison, MS InternetExplorer 5.0 has none of these 3 problems.
If issue (1) is a bug report, it would be related to the default value of the
empty-cells property, which works correctly, as seen in
http://www.fas.harvard.edu/~dbaron/css/test/tborder2.html
I believe the CSS2 default value agrees with legacy behavior.  If it doesn't,
then this could be handled in quirks mode.  I haven't tested that the CSS2
initial value is the one used.

Issues 2 and 3 are valid bugs if correct.  I will make a test case.
Created attachment 397 [details]
Test case showing bug.
Summary: doesn't handle <COL> tag of HTML 4.0 → align="center" not working on COL and COLGROUP
Created attachment 398 [details]
REVISED Test case showing bug - IGNORE FIRST TESTCASE
Whiteboard: [TESTCASE]
Marked with [TESTCASE].
Note that ALIGN and VALIGN on COL and COLGROUP cannot be done using CSS,
since CSS does not allow text-align and vertical-align to inherit through
table-columns and table-column-groups. This may be an issue to raise
in www-style.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M10

Comment 6

19 years ago
Spoke to karnaze during bug triage today.  Moving to M11.  Not an M10 blocker.
(Assignee)

Comment 7

18 years ago
Moving to M13.
(Assignee)

Comment 8

18 years ago
mass move to m14.
Target Milestone: M13 → M14
Keywords: testcase
Bulk moving [testcase] code to new testcase keyword. Sorry for the spam!

Updated

18 years ago
Keywords: beta1

Comment 10

18 years ago
Putting on on PDT- radar for beta1.  Would not hold beta for this bug.  chrisd, 
please feel free to release note at:
http://bugzilla.mozilla.org/show_bug.cgi?id=25524
Whiteboard: [TESTCASE] → [PDT-]
(Assignee)

Comment 11

18 years ago
Issues 2 and 3 are a duplicate of bug 915. I don't believe Issue 1 valid.

*** This bug has been marked as a duplicate of 915 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 12

18 years ago
Verified dup of #915
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.