Last Comment Bug 747247 - Fix assertions about null owners
: Fix assertions about null owners
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: IndexedDB (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla15
Assigned To: Ben Turner (not reading bugmail, use the needinfo flag!)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-19 16:47 PDT by Ben Turner (not reading bugmail, use the needinfo flag!)
Modified: 2012-05-17 11:08 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch, v1 (2.40 KB, patch)
2012-04-19 16:47 PDT, Ben Turner (not reading bugmail, use the needinfo flag!)
khuey: review-
Details | Diff | Splinter Review

Description Ben Turner (not reading bugmail, use the needinfo flag!) 2012-04-19 16:47:18 PDT
Created attachment 616806 [details] [diff] [review]
Patch, v1

Since the behavior of nsDOMEventTargetHelper changed to allow weak owners indexeddb code asserts stuff that it shouldn't.
Comment 1 Kyle Huey [:khuey] (khuey@mozilla.com) 2012-04-23 12:51:59 PDT
Comment on attachment 616806 [details] [diff] [review]
Patch, v1

Review of attachment 616806 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/indexedDB/IDBDatabase.cpp
@@ +221,5 @@
>  
>    // When the IndexedDatabaseManager needs to invalidate databases, all it has
>    // is an origin, so we call back into the manager to cancel any prompts for
>    // our owner.
> +  nsCOMPtr<nsPIDOMWindow> owner = GetOwner();

This does not need to be a strong pointer.  Please make it weak.
Comment 2 Kyle Huey [:khuey] (khuey@mozilla.com) 2012-05-17 11:08:33 PDT
https://hg.mozilla.org/mozilla-central/rev/5e462ce3cb42

Note You need to log in before you can comment on or make changes to this bug.