Last Comment Bug 747264 - don't sync smoothScroll/autoFill/newtabpage.enabled prefs
: don't sync smoothScroll/autoFill/newtabpage.enabled prefs
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 14
Assigned To: :Gavin Sharp [email: gavin@gavinsharp.com]
:
Mentors:
Depends on:
Blocks: 746572
  Show dependency treegraph
 
Reported: 2012-04-19 17:39 PDT by :Gavin Sharp [email: gavin@gavinsharp.com]
Modified: 2012-04-20 20:08 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (3.28 KB, patch)
2012-04-19 17:58 PDT, :Gavin Sharp [email: gavin@gavinsharp.com]
mak77: review+
Details | Diff | Review

Description :Gavin Sharp [email: gavin@gavinsharp.com] 2012-04-19 17:39:04 PDT
Having sync set up with builds of Firefox from different channels can cause trouble if we're changing a pref's default value, because sync currently syncs all prefs regardless of whether they have a default value (bug 744626). To mitigate this for the current prefs whose defaults are changing in the current trains, we should stop syncing these prefs:

- general.smoothScroll
- browser.newtabpage.enabled
- browser.urlbar.autoFill

I think it makes sense to stop syncing autoFill regardless of Sync's behavior, since it isn't user-exposed in any way. We can re-add the other two when Sync's behavior is changed.
Comment 1 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-04-19 17:58:45 PDT
Created attachment 616826 [details] [diff] [review]
patch
Comment 2 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-04-20 07:06:34 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/a1c77b5ee099
Comment 3 Phil Ringnalda (:philor) 2012-04-20 20:08:36 PDT
https://hg.mozilla.org/mozilla-central/rev/a1c77b5ee099

Note You need to log in before you can comment on or make changes to this bug.