tests for testRestartChangeArchitecture broken due to a bug in startUserShutdown

RESOLVED FIXED

Status

Mozilla QA
Mozmill Tests
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: whimboo, Assigned: whimboo)

Tracking

({regression})

unspecified
regression

Firefox Tracking Flags

(firefox13 fixed, firefox14 fixed, firefox15 fixed, firefox16 fixed, firefox-esr10 fixed)

Details

(Whiteboard: [mozmill-test-failure][needs-mozmill-1.5.13][qa-])

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
With the latest jsbridge auto-port selection feature implemented in Mozmill 1.5.10/11 we have seen that the startUserShutdown method of Mozmill is broken. That means after a restart the jsbridge connection cannot be established and the restart tests die.

Given that in Mozmill 2 the whole process handling has been rewritten, we don't intent to work on a fix for Mozmill 1.5 for now. If it's easy to backport it will be done but for the time being lets simply skip those tests across all platforms.
(Assignee)

Updated

5 years ago
Depends on: 686320
(Assignee)

Comment 1

5 years ago
Created attachment 616876 [details] [diff] [review]
Patch v1 (skip tests) [checked-in]
Attachment #616876 - Flags: review?(david.guo)

Updated

5 years ago
Attachment #616876 - Flags: review?(david.guo) → review+
(Assignee)

Comment 2

5 years ago
Comment on attachment 616876 [details] [diff] [review]
Patch v1 (skip tests) [checked-in]

Landed across all branches:
http://hg.mozilla.org/qa/mozmill-tests/rev/ca42c295e8f5 (default)
http://hg.mozilla.org/qa/mozmill-tests/rev/6b765ad876bd (aurora)
http://hg.mozilla.org/qa/mozmill-tests/rev/b4a6a26b73de (beta)
http://hg.mozilla.org/qa/mozmill-tests/rev/f8505f8acf54 (release)
http://hg.mozilla.org/qa/mozmill-tests/rev/4301d31357e9 (esr10)
Attachment #616876 - Attachment description: Patch v1 (skip tests) → Patch v1 (skip tests) [checked-in]
(Assignee)

Updated

5 years ago
Whiteboard: [mozmill-test-failure][needs-mozmill-2.0] → [mozmill-test-failure][needs-mozmill-2.0][mozmill-test-skipped]
(Assignee)

Comment 3

5 years ago
This no longer depends on Mozmill 2. Once 1.5.13 has been released we can re-enable the test again.
Depends on: 765040
No longer depends on: 686320
(Assignee)

Comment 4

5 years ago
This was actually caused by the patch on bug 686320. Now with Mozmill 1.5.13 released we can re-enable this test. For now I will do it for default and we can follow-up later (tomorrow) with the other branches.

Backed out:
http://hg.mozilla.org/qa/mozmill-tests/rev/28ffe73795ee
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
status-firefox-esr10: --- → affected
status-firefox13: --- → affected
status-firefox14: --- → affected
status-firefox15: --- → affected
status-firefox16: --- → fixed
Keywords: regression
Resolution: --- → FIXED
(Assignee)

Comment 5

5 years ago
http://hg.mozilla.org/qa/mozmill-tests/rev/3dbae5596b9a (aurora)
http://hg.mozilla.org/qa/mozmill-tests/rev/19ca247bbc78 (beta)
http://hg.mozilla.org/qa/mozmill-tests/rev/96ba678d2cd6 (release)
http://hg.mozilla.org/qa/mozmill-tests/rev/bf173c27d92b (esr10)
status-firefox-esr10: affected → fixed
status-firefox13: affected → fixed
status-firefox14: affected → fixed
status-firefox15: affected → fixed
Whiteboard: [mozmill-test-failure][needs-mozmill-2.0][mozmill-test-skipped] → [mozmill-test-failure][needs-mozmill-2.0]
(Assignee)

Updated

5 years ago
Whiteboard: [mozmill-test-failure][needs-mozmill-2.0] → [mozmill-test-failure][needs-mozmill-1.5.13]
Whiteboard: [mozmill-test-failure][needs-mozmill-1.5.13] → [mozmill-test-failure][needs-mozmill-1.5.13][qa-]
You need to log in before you can comment on or make changes to this bug.