Closed Bug 747390 Opened 8 years ago Closed 4 years ago

update service wrongly claims user cannot elevate

Categories

(Toolkit :: Application Update, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 529746

People

(Reporter: bhearsum, Unassigned)

Details

(Whiteboard: [DUPEME])

Michiel showed me a Windows 7 (Professional SP1) laptop today that was unable to update Firefox. It was in a loop, where it had downloaded the updated but "Apply Update" did nothing. I turned on update logging and found the following in the console:

Could not read chrome manifest file 'C:\Program Files (x86)\Mozilla Firefox\extensions\{972ce4c6-7e08-4474-a285-3208198ce6fd}\chrome.manifest'.
AUS:SVC gCanCheckForUpdates - able to check for updates
AUS:SVC gCanApplyUpdates - testing write access C:\Users\Mike\AppData\Local\Mozilla\Firefox\Mozilla Firefox\update.test
AUS:SVC gCanApplyUpdates - windowsVersion = 6.1
AUS:SVC gCanApplyUpdates - on Vista, userCanElevate: false
AUS:SVC gCanApplyUpdates - testing write access C:\Program Files (x86)\Mozilla Firefox\update.test
AUS:SVC gCanApplyUpdates - unable to apply updates. Exception: [Exception... "Component returned failure code: 0x80520015 (NS_ERROR_FILE_ACCESS_DENIED) [nsILocalFile.create]"  nsresult: "0x80520015 (NS_ERROR_FILE_ACCESS_DENIED)"  location: "JS frame :: resource:///components/nsUpdateService.js :: aus_gCanApplyUpdates :: line 313"  data: no]
AUS:SVC UpdateService:_postUpdateProcessing - unable to check for or apply updates... returning early


However, the user account Firefox is running as *is* able to elevate. For example, I can run Firefox as Administrator by right clicking and using "Run as", but it requires a password to do so.

It seems like userCanElevate is wrong here, or is this expected behaviour?
Is there any way I can get physical access to this machine?
Is this maybe a limited user account that's trying to apply an update when the installation is installed into program files?
This user account can elevate by getting prompted for a password.  In this case, nsXULAppInfo::GetUserCanElevate is returning false.  The exception in comment 0 is irrelevant (and expected.)

FWIW, the Firefox installation was 9.0.1.
We have only ever supported elevation from an account that is a member of the admin group. There are other bugs already filed to extend this to all user accounts.
Whiteboard: [DUPEME]
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 529746
You need to log in before you can comment on or make changes to this bug.